Error when updating jQuery

Topics: General
Apr 23, 2013 at 5:41 AM
Edited Apr 23, 2013 at 5:41 AM
Hey guys, I am getting an error when I try and install the new nugget package for jQuery. I get the following error:
PM> update-package jQuery
Updating 'jQuery' from version '1.9.1' to '2.0.0' in project 'MvcApplication1'.
update-package : Updating 'jQuery 1.9.1' to 'jQuery 2.0.0' failed. Unable to find a version of 'Microsoft.jQuery.Unobtrusive.Ajax' that is compatible with 'jQuery 2.0.0'.
At line:1 char:1
+ update-package jQuery
+ ~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Update-Package], Exception
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.UpdatePackageCommand
 
Just wondering what I need to do? Everything else is up to date??
Apr 23, 2013 at 5:46 PM
There's nothing you can do. The Microsoft.jQuery.Unobtrusive.Ajax package, which depends on jQuery, specifically states that it doesn't work with jQuery 2.0. If you look at the package in NuGet Package Explorer, you'll see that it specifies the dependency on jQuery as (>= 1.4.4 & < 2.0).