Can't fix broken package

Topics: General
May 1, 2012 at 3:57 AM

A user of one of my packages recently brought to my attention that its dependencies are incorrect. The package in question is .
Instead of '>=' version dependencies it should be all '=' dependencies.
Problem is, I can't seem to change this. If I try to push a fixed nupkg, I get this message:

"Failed to process request. 'A package with id 'SolrNet.Ninject' and version '0.3.1' already exists and cannot be modified.'.The remote server returned an error: (409) Conflict.."

I can't delete it and resubmit it either. IIRC I used to be able to do this. 

How do I fix my package?


May 1, 2012 at 8:07 AM

Please use the report abuse link on the package's page (I know it's not abuse, but it routes to the right place), and that will send the gallery team an email. We'll help you get this fixed.

May 1, 2012 at 2:57 PM

Thanks Drew, I'll do that.

Still, shouldn't there be a way to do this on my own? After all, I do own the package, and it's a minor edit.


May 1, 2012 at 4:38 PM

It's on the backlog of stuff to work on, but we haven't gotten to it yet. It's not quite as simple as you might think, as there are some changes we want to allow, and other we don't. Well, maybe. It's a discussion we need to finish and then do the work. The best place for this discussion is here:

May 1, 2012 at 5:15 PM

I know, it can be more trouble than it's worth. I actually kind of agree with the current position, I was just a bit surprised when I couldn't change it when I used to be able to.


May 1, 2012 at 5:17 PM

I changed a few things when we re-wrote the gallery. :)