Server return 404 when installing package from custom remote feed

Mar 5, 2012 at 2:48 PM
Edited Mar 5, 2012 at 2:50 PM

Hi all,

I have followed the following tutorial for creating a custom feed:

I exported the NuGet server by creating a deployment package through Visual Studio 2010, but because i couldn't get the installer to run properly on the server, i simply dropped the contents of the deployment package's zip file in the virtual directory. Of course without all the configuration xml etc.

I then tried to access the feed through my browser. All was still well and i was able to open the feed. I tried downloading the .nupkg package directly, but IIS returned me 404 pages. I had to add the MIME type application/zip to the Web Site in IIS to be able to download the nupkg file directly.

After that i went to Visual Studio, i was able to download the feed, but when i wanted to install the package i got a 404 page. My problem looks very similar to the problem as described at: , however the fix turns all my pages into 404's, even direct GET requests of the Default.aspx page.

Through fiddler i found that the GET request of the NuGet plugin to the server is: GET /api/v2/package/c4.core.common/ HTTP/1.0

I don't have a folder api, so i guess it has to do with the rerouting that should occur. I think that is what is being suggested in the solution in the previous link that i have provided, but which im not getting to work. I must admit that i'm a novice with IIS, so i may overlook something very trivial.

My current setup is IIS 6.0, and the NuGet feed is hosted in a virtual directory under the wwwroot called nuget (I.e. C:\Inetpub\wwwroot\nuget)

Your help would be much appreciated.

Kind regards,


Mar 5, 2012 at 2:57 PM

Make sure you unchecked the "Verify that file exists" checkbox when you added the wildcard mapping. No one on the NuGet team uses IIS 6, so I don't know how much help we'll be able to provide.

Mar 6, 2012 at 7:00 AM

That worked! Thanks a lot. Now that i've read up about the option it makes sense.