Dialog10 compilation error

Feb 20, 2012 at 3:16 PM

I'm getting the following compilation error while compiling Dialog10 project in nuget solution

Assembly 'NuGet.Dialog10, Version=1.7.0.0, Culture=neutral, PublicKeyToken=null' uses 'Microsoft.VisualStudio.Shell.10.0, Version=11.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' which has a higher version than referenced assembly 'Microsoft.VisualStudio.Shell.10.0, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'	......\nuget\src\Dialog10\bin\Debug\NuGet.Dialog10.dll	VsExtension
i'n using Visual Studio 11 version 11.0.40825.2 prerel
Feb 25, 2012 at 3:31 PM

Same here... wondering what's causing this thing . . .hope nuget will be able to give a solution to this problem before this coming monday so i can finish my work  :(

__________________________________________

Personal Success

Feb 26, 2012 at 3:29 PM

Currently compiling NuGet in VS 11 is not supported.

@ingrdjackson2012: I'm curious as to what your work is that depends on compiling NuGet on VS11?

Feb 26, 2012 at 3:43 PM

I've manage to compile the solution after doing the following:

change each reference to "Microsoft.VisualStudio.Shell.10.0.dll" from version 11 to version 10