1.6 Nuget is asking for Credentials but wont accept any

Feb 2, 2012 at 9:08 PM

Hi All,
I updated my nuget.server to 1.6. Before 1.6 everything was working on the same machine with the same config.

I just republished the 1.6 project something like this:

-created the new project

-added the NuGet.Server to the projects

-added a apiKey - nuget

-changed the packages path to c:\NugetPackages (which has rights for all users i tried playing around with this)...

When i attempt to publish i get:

nuget push C:\mypath\mypackage1.2.887.nupkg -s http://myserver.com:8000
/NuGet nuget

Pushing mypackage1.2.887 to 'http://myserver.com:8000/NuGet
Please provide credentials for: http://myserver.com:8000/NuGet/
UserName: ss
Password: ***
Cannot access a closed Stream.

No matter which correct credentials i use it will not publish... What could be causing this?


Feb 2, 2012 at 9:14 PM
Edited Feb 2, 2012 at 9:14 PM

Change the source to http://myserver.com:8080. (no trailing path, just the host). We made some route changes in 1.6 to allow cleaner source urls.

Feb 2, 2012 at 9:25 PM

That doesnt work, actually the app is published to a virtual directory NuGet...So thats the root of the path.

Failed to process request. 'Not Found'.
The remote server returned an error: (404) Not Found..

I also tried something suggested on another post /api/v2 which also does not work..

If i go to this page..


I see the standard page with all my packages and the link suggests:

nuget push {package file} -s http://myserver.com:8000/NuGet/ {apikey}


Feb 2, 2012 at 9:31 PM

Ok, as of our previous release our route cleanup basically meant appending a magical token if we detected the source was a host without a path. We planned on adding better aut-detection support in 1.7 but that hasn't happened as of yet.

Specify the source as http://myserver.com:8000/NuGet/api/v2/ and that should resolve the issue.

Feb 3, 2012 at 1:13 PM


C:\Windows\system32>nuget push MyPackage.nupkg -s http://myserver.com:8000
/NuGet/api/v2/package/ nuget


May 30, 2013 at 9:58 PM
We are running the latest version 2.5.0 and trying to post to a local machine. we've struggled with this for 2 days and are now getting the repeated "Please provide credentials for: http://dvm1nuget:80/api/v2/package/". We've made sure that there are amble permissions on the directory and still are getting no where...

Thanks in advance