Error: Value cannot be null

Jan 11, 2012 at 4:05 PM

Hello all,

I recently installed NuGet for Visual Studio 2010 Professional.

I was also able to install same external packages. Since yesterday I am not able to get an overview of available packages any more.

In the Dialog appear the error message: Value cannot be null. Parameter name: frameworkName.

I also tried to uninstall and reinstall nuget version without any change. If I try to get the list of available packages over the powershell command console, it works withou problem. 

I have nuget Version 1.6.21215.9133 on a Windows 7 64bit system. 

I search the internet for similar problems, but found only one entry in the issue tracker regarding the version 1.5 of nuget.

Help would be very nice

best regards


Jan 11, 2012 at 4:15 PM

Hello all,

I just sortet out, that this only happens, when no project or solution is selected. 

So its more a user error (maybe nuget could give a hint, that a project should be selected).

best regards


Jan 13, 2012 at 6:57 PM

I believe we have fixed this bug recently.

Apr 24, 2012 at 3:06 PM

I'm getting this error with 1.7, but only in some of my solutions and only for "Manage NuGet Packages for Solution...". I started removing projects from the solution one-by-one and discovered that the error occurs when a solutions contains a WIX project.

Apr 24, 2012 at 3:12 PM

see issue

Apr 24, 2012 at 3:46 PM

thanks for the info. we'll fix it in 1.9

Jun 18, 2012 at 7:10 PM

This also happens in VS2011 and the 1.8 version of NuGet. Still some pretty rough edges working with TFS source control and beta and rc versions of a package.

Sep 18, 2012 at 10:50 PM

I've encountered with this bug on NuGet 2.0.30717.9005 (in VS2010).

I open "Manage packages" dialog for solution, go to "Online" tab and for any non-empty sourse I see this error message.  If I open the dialog for each project of the solution then there's no the error.

If I create a new solution from scratch then there's no the error. But in this particular solution it is.

I tried reinstall NuGet, delete .nuget and imports of nuget.targets in the solution projects and then again "Enable package restore". No luck.

Sep 20, 2012 at 7:55 PM

We have fixed this bug (for sure this time) in the upcoming NuGet 2.1.

Feb 6, 2013 at 9:07 AM
Edited Feb 6, 2013 at 9:08 AM
I just got the message "Value cannot be null. Parameter name : source" in Visual Studio 2010 and NuGet 2.2.0
Is this related to "frameworkName"?
Feb 6, 2013 at 5:54 PM
You need to provide more information for us to diagnose the problem. What were you trying to do? What is the content of the file %appdata%\NuGet\nuget.config?
Feb 7, 2013 at 12:59 PM

I figured it out, it's not related to framework.

The problem was Nexus authentication.
The password of the user expired / was saved incorrectly.

Here is where I'm speculating:
Because the authentication failed, Nexus returned a null list of some sort to NuGet (an empty list of available repositories perhaps?)

relogin to Nexus solved it.

B.T.W I couldn't find an easy way to force NuGet to logout and login again out of Nexus.
Mar 1, 2013 at 10:27 AM
Edited Mar 1, 2013 at 10:28 AM

I am getting a similar issue with VS 2012 Premium Update 1 / NuGet 2.2. I am not using Nexus or anything fancy, just the default package source.
Every time I try to click the "Manage" button on an installed package in the Solution, I get the "Value cannot be null" message box. See for details.
Mar 1, 2013 at 12:54 PM
You filed the bug at the wrong place. :) You filed it on the CodePlex project instead of NuGet.
Mar 1, 2013 at 2:44 PM
Oops, sorry - is it possible to move the bug to the proper place? I'll try out the nightly.
Mar 1, 2013 at 4:47 PM
Can you open a new issue on NuGet? We should not continue commenting in there. The CodePlex team will eventually close it.
Mar 1, 2013 at 5:32 PM
Done. I was hoping the tracker's owner can move the bug, but looks like that's not possible.
Sorry for the mistake, I got browser tabs mixed up ...