Framework version specific config transforms

Jan 9, 2012 at 5:46 PM

I have a package that supports multiple versions of the .net framework, each with their own assembly versions. I want to limit the web.config transformation I have to only apply to .NET 4.0 or later, as it uses an extension point added in 4.0. If the transform runs in 2.0 or 3.5 then the resultant web.config has invalid attributes and the app won't start.

Is this possible?

Developer
Jan 9, 2012 at 5:49 PM

Not as of now. However we're planning on adding target framework support to content files in 1.7 (http://nuget.codeplex.com/workitem/221)