Dependency version

Dec 22, 2011 at 6:40 AM

I have the following packages as follows

  •  MyDll.dll : version
    • Dependency
      • OtherDll.dll : version
  • OtherDll.dll : version

However when I install MyDll.dll package it installs version of OtherDll.dll, inspite of specifying version in the dependencies for MyDll.dll package. It seems to install the latest version for the dependent packages and seems to ignore the version specified.

Is this a bug or am I missing something?




Dec 22, 2011 at 2:00 PM

It's the right behavior. Check out to see how version specification works.