Unable to connect to the remote server - Nuget

Sep 13, 2011 at 7:35 PM

Hi All,

I am trying to setup nuget server . Initially I set it up on my home PC and it worked perfectly fine with VS2010 and MVC 3. Now when I set it up on the server, I am unable to install any nuget package . The error that I am receiving is" Unable to connect to the remote server"

I am trying to execute the below statement:

install-package nuget.server

Attempting to resolve dependency 'NuGet.Core (≥ 1.5)'.Attempting to resolve dependency 'WebActivator (≥ 1.4.1)'.Attempting to resolve dependency 'Ninject (≥ 2.2.1.4)'.Attempting to resolve dependency 'elmah (≥ 1.2.0.1)'.Install-Package : At line:1 char:16+ install-package <<<<  nuget.server    + CategoryInfo          : NotSpecified: (:) [Install-Package], WebException    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageComman

I checked the Windows firewall and have currently even turned it off but still get this error. The source link https://go.microsoft.com/fwlink/?LinkID=206669 in the browser seems accessible but redirects me to - http://packages.nuget.org/v1/FeedService.svc/ 

<service xml:base="http://packages.nuget.org/v1/FeedService.svc/"><workspace><atom:title>Default</atom:title><collection href="Packages"><atom:title>Packages</atom:title></collection><collection href="Screenshots"><atom:title>Screenshots</atom:title></collection></workspace></service> 

Need some help to resolve this soon.

 

Thanks

Madhu m

Developer
Sep 13, 2011 at 7:43 PM

Did you paste the error? I'm not seeing the exact error text.

Sep 13, 2011 at 7:56 PM

Hello,

The error is :  Unable to connect to the remote server" 

In power shell the error is:

Install-Package : Unable to connect to the remote serverAt line:1 char:16+ install-package <<<<  nuget.server    + CategoryInfo          : NotSpecified: (:) [Install-Package], WebException    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

Sep 14, 2011 at 6:57 AM

Hi,

Does it use any google API link in order to download any package when I use power-shell ?

 

thanks

Madhu m

Aug 6, 2012 at 3:50 PM

Did you ever find a solution or way to debug/trouble shoot this type of issue for private repositories?

Aug 15, 2012 at 5:06 PM

I'M GETTING SOME LIKE THAT. I CAN'T INSTALL ANY PACKAGES...

"remote name could not be resolved: 'az320820.vo.msecnd.net'"