Install-Package : The remote name could not be resolved: ''

Jul 17, 2011 at 8:09 AM


For no reason, I have been getting this error message for a week or so;

PM> Install-Package Elmah
Install-Package : The remote name could not be resolved: ''
At line:1 char:16
+ Install-Package <<<<  Elmah
    + CategoryInfo          : NotSpecified: (:) [Install-Package], WebException
    + FullyQualifiedErrorId : System.Net.WebException,NuGet.PowerShell.Commands.InstallPackageCommand
when I navigate to the link in my browser, I see the proper ODATA Nuget Feed. Can u help me on this? what blocks me to get to

Jul 17, 2011 at 8:10 AM

Can you run fiddler to see whether requests are correctly sent from nuget?

Jul 17, 2011 at 8:46 AM


fiddler doesn't capture anything when I run the following command;

PM> Install-Package Elmah
Jul 17, 2011 at 8:50 AM
Edited Jul 17, 2011 at 8:52 AM

Checked the feed's fwlink url, it works fine on the browser as well;

I tried the Manage Nuget Packages dialog box, the same error there. 

BTW, my internal nuget servers works fine.

Jul 18, 2011 at 4:15 AM

Strange that no requests are being made. Are you going through a proxy? Also, in VS does the the Extension Manager (under Tools) work correctly in the online tab?