Not able to see any packages in "Add library package reference"

Jan 19, 2011 at 9:13 PM

Hi

I just installed powershell 2.0 and Nuget extension however I am not able to see  any items in "add library package reference"

Can Anyone help?

 

Thanks
"

Coordinator
Jan 19, 2011 at 9:14 PM

Did you click the “Online” tab?

Jan 19, 2011 at 10:40 PM

Yes I did, Nothing showing up in online tab. Anything else you want me to check?

Jan 21, 2011 at 3:09 AM
Edited Jan 21, 2011 at 3:10 AM

I'm also having this kind of issue. When I try to manually retrieve the feed from the browser, I got the xml below.

from http://go.microsoft.com/fwlink/?LinkID=206669 which redirects to http://packages.nuget.org/v1/FeedService.svc/

 <?xml version="1.0" encoding="utf-8" standalone="yes" ?> 
 <service xml:base="http://packages.nuget.org/v1/FeedService.svc/" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:app="http://www.w3.org/2007/app" xmlns="http://www.w3.org/2007/app">
 <workspace>
  <atom:title>Default</atom:title> 
 <collection href="Packages">
  <atom:title>Packages</atom:title> 
  </collection>
 <collection href="Screenshots">
  <atom:title>Screenshots</atom:title> 
  </collection>
  </workspace>
  </service>
Developer
Jan 21, 2011 at 3:28 AM

Try clearing your ie cache.

Jan 21, 2011 at 3:42 AM

@arvinbb: yes, what you are getting in the browser is exactly what you should get, so no problem there.  Or am I missing something?

Jan 26, 2011 at 4:56 PM

Hi @arvinbb , @dfowler and @davidebbo , do you guys have any update for this issue. Thanks

Jan 26, 2011 at 5:25 PM

Can you run $Host.Version in the PowerShell console to see what version you have?

Jan 26, 2011 at 5:40 PM

Hi davidebbo

 

Please find below results. Thanks

PM> $Host

 

Name : Package Manager Host

Version : 1.0.11220.104

InstanceId : 6da1902a-f81f-46d1-9bad-8eb68722c992

UI : System.Management.Automation.Internal.Host.InternalHostUserInterface

CurrentCulture : en-US

CurrentUICulture : en-US

PrivateData : NuGetConsole.Host.PowerShellProvider.PowerShellHostProvider+Commander

IsRunspacePushed :

Runspace :

 

 

PM> $Host

.

version

Major Minor Build Revision

----- ----- ----- --------

1 0 11220 104

Jan 26, 2011 at 6:05 PM

And did you confirm that your package source points to http://go.microsoft.com/fwlink/?LinkID=206669?  If so, can you try running fiddler to see whether any http requests are being made?  One more thing: try running 'get-package -r' from the PowerShell NuGet console.

Jan 26, 2011 at 6:13 PM

Yes , get-package -r doensn't give any results. same as GUI.

Jan 26, 2011 at 6:15 PM

Did you try the other suggestions? :)

Jan 26, 2011 at 6:35 PM

Hi

I tried fiddler and got below 4 https request made when I try to access packages from visual studio.

 

 

---------------

 

Request Count:  1

#

Result Protocol Host URL Body Caching Content-Type Process Comments Custom
249 200 HTTP packages.nuget.org /v1/FeedService.svc/Packages()/$count 3 no-cache text/plain;charset=utf-8 devenv:8048    

Bytes Sent:  218 (headers:218; body:0)
Bytes Received: 321 (headers:318; body:3)

ACTUAL PERFORMANCE
--------------
ClientConnected: 11:28:54.341
ClientBeginRequest: 11:28:54.341
ClientDoneRequest: 11:28:54.341
Gateway Determination: 0ms
DNS Lookup:   0ms
TCP/IP Connect:  0ms
HTTPS Handshake: 0ms
ServerConnected: 11:28:03.280
FiddlerBeginRequest: 11:28:54.341
ServerGotRequest: 11:28:54.341
ServerBeginResponse: 11:28:54.404
ServerDoneResponse: 11:28:54.404
ClientBeginResponse: 11:28:54.404
ClientDoneResponse: 11:28:54.404

 Overall Elapsed: 00:00:00.0624988

RESPONSE CODES
--------------
HTTP/200:  1

RESPONSE BYTES (by Content-Type)
--------------
 ~headers~: 318
text/plain: 3

 

----------------------------

# Result Protocol Host URL Body Caching Content-Type Process Comments Custom
250 200 HTTP packages.nuget.org /v1/FeedService.svc/Packages()?$orderby=Rating%20desc,Id&$skip=0&$top=30 106,383 no-cache text/xml;charset=utf-8 devenv:8048    

Request Count:  1
Bytes Sent:  249 (headers:249; body:0)
Bytes Received: 106,704 (headers:321; body:106383)

ACTUAL PERFORMANCE
--------------
ClientConnected: 11:28:54.404
ClientBeginRequest: 11:28:54.404
ClientDoneRequest: 11:28:54.404
Gateway Determination: 0ms
DNS Lookup:   0ms
TCP/IP Connect:  0ms
HTTPS Handshake: 0ms
ServerConnected: 11:28:02.952
FiddlerBeginRequest: 11:28:54.404
ServerGotRequest: 11:28:54.404
ServerBeginResponse: 11:28:54.622
ServerDoneResponse: 11:28:54.638
ClientBeginResponse: 11:28:54.638
ClientDoneResponse: 11:28:54.638

 Overall Elapsed: 00:00:00.2343705

RESPONSE CODES
--------------
HTTP/200:  1

RESPONSE BYTES (by Content-Type)
--------------
text/xml: 106,383
~headers~: 321

 

 

 

-----------------------------------------------------

 

# Result Protocol Host URL Body Caching Content-Type Process Comments Custom
251 200 HTTP packages.nuget.org /v1/FeedService.svc/Packages()/$count 3 no-cache text/plain;charset=utf-8 devenv:8048    

Request Count:  1
Bytes Sent:  188 (headers:188; body:0)
Bytes Received: 321 (headers:318; body:3)

ACTUAL PERFORMANCE
--------------
ClientConnected: 11:28:54.638
ClientBeginRequest: 11:28:55.310
ClientDoneRequest: 11:28:55.310
Gateway Determination: 0ms
DNS Lookup:   0ms
TCP/IP Connect:  0ms
HTTPS Handshake: 0ms
ServerConnected: 11:28:03.280
FiddlerBeginRequest: 11:28:55.310
ServerGotRequest: 11:28:55.310
ServerBeginResponse: 11:28:55.341
ServerDoneResponse: 11:28:55.341
ClientBeginResponse: 11:28:55.341
ClientDoneResponse: 11:28:55.341

 Overall Elapsed: 00:00:00.0312494

RESPONSE CODES
--------------
HTTP/200:  1

RESPONSE BYTES (by Content-Type)
--------------
 ~headers~: 318
text/plain: 3

--------------------------------------------------------------------------

# Result Protocol Host URL Body Caching Content-Type Process Comments Custom
252 200 HTTP packages.nuget.org /v1/FeedService.svc/Packages()?$orderby=Rating%20desc,Id&$skip=0&$top=30 106,383 no-cache text/xml;charset=utf-8 devenv:8048    

Request Count:  1
Bytes Sent:  249 (headers:249; body:0)
Bytes Received: 106,704 (headers:321; body:106383)

ACTUAL PERFORMANCE
--------------
ClientConnected: 11:28:55.341
ClientBeginRequest: 11:28:55.341
ClientDoneRequest: 11:28:55.341
Gateway Determination: 0ms
DNS Lookup:   0ms
TCP/IP Connect:  0ms
HTTPS Handshake: 0ms
ServerConnected: 11:28:02.952
FiddlerBeginRequest: 11:28:55.341
ServerGotRequest: 11:28:55.341
ServerBeginResponse: 11:28:55.451
ServerDoneResponse: 11:28:55.466
ClientBeginResponse: 11:28:55.466
ClientDoneResponse: 11:28:55.466

 Overall Elapsed: 00:00:00.1249976

RESPONSE CODES
--------------
HTTP/200:  1

RESPONSE BYTES (by Content-Type)
--------------
text/xml: 106,383
~headers~: 321

 

Jan 26, 2011 at 7:08 PM

Those look like what they should be.  Very puzzling that this doesn't result any anything being displayed in the NuGet's dialog's online tab.  Do others have any thoughts?