Local repository shows up empty

Dec 3, 2010 at 3:29 PM

I'm having trouble getting a local repository to work. Here's what I did:

  1. Installed NuGet Tools from VS extensions gallery (says version 0.2)
  2. Forked and cloned http://nupackpackages.codeplex.com/
  3. Added my new packages to my clone
  4. Built everything with RebuildPackages.cmd as the instructions say. Everything builds ok.
  5. Added my local path as package source.

Now if I go to the package manager console and run list-package and I get a lot of empty lines (apparently one for each package).

If I try to add a package via VS, I also get a list of empty items (screenshot: http://i.imgur.com/Uct7e.png)

Any ideas? This seems to be a version mismatch or something.

Thanks

Coordinator
Dec 3, 2010 at 4:52 PM

Can you post an example of on of the "nuspec" files you used to generate the packages?

Dec 3, 2010 at 5:01 PM

Here's the nuspec of one of the packages I added:

<?xml version="1.0" encoding="utf-8"?>
<package>
  <metadata>
    <id>SolrNet</id>
    <version>0.3.0</version>
    <description>Apache Solr client</description>
    <authors>
      <author>Mauricio Scheffer and contributors</author>
    </authors>
    <licenseUrl>http://www.apache.org/licenses/LICENSE-2.0</licenseUrl>
    <language>en-US</language>
    <requireLicenseAcceptance>false</requireLicenseAcceptance>
    <created>2010-12-03T01:54:31.07925-03:00</created>
    <modified>2010-12-03T01:54:31.07925-03:00</modified>
  </metadata>
  <dependencies>
    <dependency id="CommonServiceLocator" version="1.0" />
  </dependencies>
</package>

Coordinator
Dec 3, 2010 at 5:06 PM

The NuSpec format has changed recently. Which exact build are you running? Check out the docs here: http://nuget.codeplex.com/documentation?title=Nuspec%20Format

For example, <authors> is a comma separated list and dependencies belong in the metadata.

Phil

From: mausch [mailto:notifications@codeplex.com]
Sent: Friday, December 03, 2010 9:01 AM
To: Phil Haack
Subject: Re: Local repository shows up empty [nuget:237044]

From: mausch

Here's the nuspec of one of the packages I added:

<?xml version="1.0" encoding="utf-8"?>
<package>
  <metadata>
    <id>SolrNet</id>
    <version>0.3.0</version>
    <description>Apache Solr client</description>
    <authors>
      <author>Mauricio Scheffer and contributors</author>
    </authors>
    <licenseUrl>http://www.apache.org/licenses/LICENSE-2.0</licenseUrl>
    <language>en-US</language>
    <requireLicenseAcceptance>false</requireLicenseAcceptance>
    <created>2010-12-03T01:54:31.07925-03:00</created>
    <modified>2010-12-03T01:54:31.07925-03:00</modified>
  </metadata>
  <dependencies>
    <dependency id="CommonServiceLocator" version="1.0" />
  </dependencies>
</package>

Read the full discussion online.

To add a post to this discussion, reply to this email (nuget@discussions.codeplex.com@discussions.codeplex.com)

To start a new discussion for this project, email nuget@discussions.codeplex.com@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Dec 3, 2010 at 5:21 PM

Ah, stupid me, I forgot to update the hg repo after pulling (still a hg newbie), so I was using an older version.

Thanks

Dec 3, 2010 at 5:22 PM

But what doesn't make sense here is that he says that all packages he built from our nupackpackages repo show up as empty, and those packages should definitely be correct (since our live feed uses them).  Am I missing something?  Can you look at the nuspec of some of the other packages and check if they use the old or new syntax?  e.g. their should be no <author> tag inside of <authors>.

Dec 3, 2010 at 5:23 PM

Ah, that would do it :)