References > Add Package Reference Crashes IDE

Oct 7, 2010 at 2:06 PM


I just installed Nupack, restarted Visual Studio, opened my current web project and clicked on References > Add Package. The "Add Package Reference" window appears, but the IDE crashes instantly after.

I was able to reproduce this bug twice in a row, so I assume that it always occurs with my web project. The problem does not occur when working with a brandnew project, but that doesn't really help...

In case it matters: I am using Visual Studio 2010 Ultimate.

Please help! NuPack looks really great and I'd love to have this tool at my disposal. :-)



Oct 7, 2010 at 2:15 PM

Do you have the Reflector add-in installed to? See the known issues on this.

Oct 7, 2010 at 5:00 PM

Can you run devenv /log and do the same thing. Then attach the Activity.xml so we can see what happened?

Oct 7, 2010 at 7:36 PM

@bsimser: Reflector was once installed, but that's a few months ago. It does not show in the list of Add-Ins in Visual Studio anymore.

@dfowler: I just tried (even twice!), but for some reason there is no Activity.xml on my hard disk. I've looked view everything search and also manually in in C:\Users\Adrian\AppData\Roaming\Microsoft\VisualStudio\9.0. I did find ActivityLog.xsl in that directory, but no Activity.xml. Also, I made sure I run it with "devenv /log" . Not sure what is going on...