1

Closed

3.0 CTP1 : The 'content-type' header must be modified using the appropriate property or method. Parameter name: name

description

I'm getting this error when checking for updates from nuget.org.

file attachments

Closed Aug 7 at 8:39 PM by danliu
verified the original scenario works using latest VSIX from master branch.

comments

danliu wrote Jul 22 at 8:36 PM

can you please provide more details? Are you using the powershell console? If so, what's the PS command. Also do you have a proxy or anything set up?

michaelaird wrote Jul 22 at 10:12 PM

I get this when I chose "Manage Nuget Packages for Solution" and go to Updates

No proxies.

danliu wrote Jul 22 at 11:07 PM

Thanks. does it repro for all solutions or just one solution with specific packages?

michaelaird wrote Jul 23 at 5:15 PM

Seems to be specific to the solution. Is there a way that I can get you the list of packages it is checking for?

danliu wrote Jul 24 at 4:44 PM

can you please attach that solution, or create a simple repro solution (basically empty) with the same versions of packages installed?

That would definitely help us diagnose the issue, thanks!

michaelaird wrote Jul 25 at 4:03 PM

It seems to occur when there are a lot of packages not because of a specific package. i tried removing different packages and it would start working at some point. i reverted and started removing different packages and again, it started working at some point.

here are 2 package config files. 1 fails and the other succeeds.

michaelaird wrote Jul 25 at 4:53 PM

(my attachment isn't working. send me an email at michael [at] campbrain.com and i'll send you the zip file.

michaelaird wrote Jul 25 at 4:55 PM

nevermind. my attachment went above, instead of with my comment. i hate codeplex.

danliu wrote Jul 28 at 8:45 PM

Thanks for the attachment. We can repro it with the package.config-fail.

Will investigate, thanks.

juste wrote Aug 1 at 8:44 PM

Fixed in 74856940f726a6a164cc6f99783f30157ef8b6f7

danliu wrote Aug 6 at 7:25 PM

now if I click update all button from the Update tab, I'll get a null reference exception. Reactivate the bug.

juste wrote Aug 7 at 8:29 PM

The null ref exception from installing updates is unrelated to this bug which was caused by the shim's lack of support for POST/batching.