This project is read-only.


Consider renaming the command text "Add Library Package Reference"


First of all, this dialog can do both install packages and uninstall packages. Calling it "Add" is not entirely accurate.
Second of all, in the console, we renamed Add-Package to Install-Package a long time ago. Hence, "Add" is not consistent with the console.

Let's call it "Manage NuGet Packages".

We're using "NuGet" here to denote the type of package.
Closed May 28, 2011 at 1:42 AM by bhaveshc
Verified that Add Library package reference has been renamed in the context menu for project, website and solution and also under tools menu


dfowler wrote May 5, 2011 at 5:37 AM

Manage maybe? "Manage Packages"

dotnetjunky wrote May 5, 2011 at 5:38 AM

I'm thinking "Library Packages Manager", similar to "Extension Manager".

Haacked wrote May 5, 2011 at 6:30 AM

Maybe "Package Manager". I want to move away from "Library Package". Alternatively, we could call it "Manage NuGet Packages".

stevenlauwers22 wrote May 6, 2011 at 9:30 AM

In my opinion 'Package Manager' or 'NuGet Package Manager' is the most accurate and it's similar to 'Extension Manager' as well.

Haacked wrote May 10, 2011 at 10:26 PM

Consider this for NuGet 2.0. There's a lot of existing info/docs/videos out there using the existing menu.

Haacked wrote May 10, 2011 at 10:27 PM

Unless you want to submit a patch, we probably won't fix.

** Closed by Haacked 05/10/2011 2:27PM

Haacked wrote May 10, 2011 at 10:28 PM


dotnetjunky wrote May 24, 2011 at 12:12 AM

Fixed in changeset:

Rename it to Manage Library Packages.

Haacked wrote May 24, 2011 at 12:30 AM

In our iteration planning meeting, we all agreed to change it to "Manage NuGet Packages". Otherwise we'll confuse customers.