local Nuget Gallery

Topics: General
Dec 8, 2014 at 6:31 PM
I have installed the local nuget gallery regarding https://github.com/NuGet/NuGetGallery

Everything looks well (I can create an account, upload package..) but if I click to packages
http://localhost/packages then I get an error message below. (Do I have to set path to package repository?)

No connection could be made because the target machine actively refused it 168.62.108.202:443
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 168.62.108.202:443

Source Error:

Line 24: using (Trace.Activity(request.Method + " " + request.RequestUri.AbsoluteUri))
Line 25: {
Line 26: resp = await base.SendAsync(request, cancellationToken);
Line 27: }
Line 28:


Source File: c:\NuGetGallery\src\NuGetGallery\Infrastructure\TracingHttpHandler.cs Line: 26

Stack Trace:

[SocketException (0x274d): No connection could be made because the target machine actively refused it 168.62.108.202:443]
System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult) +6643541
System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception) +271

[WebException: Unable to connect to the remote server]
System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) +6454322
System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar) +64


Thanks,
Karel
Dec 10, 2014 at 2:24 PM
You have to change the web.config

The following entry is causing this issue:
    <!-- Set this value to use a remote search service. This overrides ALL other Lucene-related settings and disables indexing jobs. -->
    <add key="Gallery.SearchServiceUri" value="https://api-search.nuget.org" />
Comment it out or remove it.

This should solve the issue
Dec 10, 2014 at 2:27 PM
Thanks. It fixed the issue.