Error: requires NuGet client version '2.8.1' or above, but the current NuGet version is '2.7.41115.310'

Topics: General
Oct 16, 2014 at 4:40 PM
I'm working with an existing solution - beginning this morning attempts to build the project toss a compile-time error:
Error   12  The 'Microsoft.Net.Http 2.2.27-beta' package requires NuGet client version '2.8.1' or above, but the current NuGet version is '2.7.41115.310'.  
When I inspect the .exe at the file system level I'm seeing the 2.7xx version but when I ask visual studio for the version I'm seeing 2.8.

Image

I've attempted an a manual update by visiting the project page but am informed that no products are eligible for update. I uninstalled and was then permitted to install but nothing changed as regards the error condition.

Next?