nuget delete fails with "Not Found'

Topics: General
Oct 2, 2014 at 8:28 AM
I must be doing something pretty basic wrong. I've got 170 packages I want to delist (in favor of some replacement ones). So, I thought I'd script it from the command line. However, here is a sequence of commands I would have expected to succeed:
PS C:\Users\Gordon> nuget list ROOTNET-Graphing-v5.32.01.win32.vc10
ROOTNET-Graphing-v5.32.01.win32.vc10 2.6
PS C:\Users\Gordon> nuget delete ROOTNET-Graphing-v5.32.01.win32.vc10 2.6
ROOTNET-Graphing-v5.32.01.win32.vc10 2.6 will be deleted from the the NuGet gallery (https://www.nuget.org). Would you l
ike to continue? (y/N) y
Deleting ROOTNET-Graphing-v5.32.01.win32.vc10 2.6 from the the NuGet gallery (https://www.nuget.org).
Failed to process request. 'Not Found'.
The remote server returned an error: (404) Not Found..
PS C:\Users\Gordon>
What am I doing wrong?
Oct 3, 2014 at 5:10 PM
can you call nuget delete ROOTNET-Graphing-v5.32.01.win32.vc10 2.6 -verbosity detailed to get more detailed exception/stacktrace?

One more thing is to open fiddler to see the exact call that gets a 404.
Oct 3, 2014 at 9:54 PM
Thanks! Here is the verbosity dump:
PS C:\Users\Gordon> nuget delete -noninteractive ROOTNET-Graphing-v5.32.01.win32.vc10 2.632.vc10 2.6 -verbosity detailed

Deleting ROOTNET-Graphing-v5.32.01.win32.vc10 2.632.vc10 from the the NuGet gallery (https://www.nuget.org).
DELETE https://www.nuget.org/api/v2/package/ROOTNET-Graphing-v5.32.01.win32.vc10/2.632.vc10
System.InvalidOperationException: Failed to process request. 'Not Found'.
The remote server returned an error: (404) Not Found.. ---> System.Net.WebException: The remote server returned an error
: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at NuGet.RequestHelper.GetResponse()
   at NuGet.HttpClient.GetResponse()
   at NuGet.PackageServer.EnsureSuccessfulResponse(HttpClient client, Nullable`1 expectedStatusCode)
   --- End of inner exception stack trace ---
   at NuGet.PackageServer.EnsureSuccessfulResponse(HttpClient client, Nullable`1 expectedStatusCode)
   at NuGet.PackageServer.DeletePackageFromServer(String apiKey, String packageId, String packageVersion)
   at NuGet.PackageServer.DeletePackage(String apiKey, String packageId, String packageVersion)
   at NuGet.Commands.DeleteCommand.ExecuteCommand()
   at NuGet.Commands.Command.Execute()
   at NuGet.Program.Main(String[] args)
PS C:\Users\Gordon>
I don't have fiddler installed on my system, so that will take me a little longer...
Oct 3, 2014 at 10:05 PM
Ok - fiddler seems to say basically the same thing - that URL is requested with a verb DELETE, and 404 is returned. Is there something specific I should find from fiddler?

BTW, I checked with "update -self" and I am running v2.8.2.