Unable to download anything from nuget, even though the nuget source is accessible in the browser

Topics: General
Aug 13, 2014 at 6:29 PM
While search is working just fine, I'm unable to actually download any packages off of nuget. I've tried changing the nuget source and seen the same results.

As a sample package, I tried to install Glimpse:
PM> Install-Package Glimpse
The source at NuGet Source [http://packages.nuget.org/v1/FeedService.svc] is unreachable. Falling back to NuGet Local Cache at C:\Users\cwhiten\AppData\Local\NuGet\Cache
Install-Package : Unable to find package 'Glimpse'.
At line:1 char:16
+ Install-Package <<<<  Glimpse
    + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
I can access http://packages.nuget.org/v1/FeedService.svc in my browser without issue. How can I debug and solve this issue?
Aug 22, 2014 at 10:57 PM
Edited Aug 22, 2014 at 11:03 PM
Same deal here. If I uninstall and reinstall NuGet, it works for one single package, then stops working. Using Fiddler I confirm that no request is even being made after the first one. The nuget source is reachable from everything except Nuget itself.
The source at nuget.org [https://www.nuget.org/api/v2/] is unreachable. Falling back to NuGet Local Cache
Aug 22, 2014 at 11:19 PM
Edited Aug 23, 2014 at 1:32 AM
I can work around this by deleting my NuGet.config. This works once, then NuGet makes a new config file for me.

EDIT: this doesn't work reliably.
Nov 6, 2014 at 11:50 AM
Hi Guys,

I had a similar issue with other packages and what it usually was is the fact that I had to accept a licence agreement.
So I added the package through the UI. Manage Packages for SOlution...

This allows you to accept the agreement

Nov 14, 2014 at 11:44 AM
Edited Nov 14, 2014 at 11:48 AM
I have this issue with the new VS 2015 Preview, with packages without license info or anything, and even with a nuget.config with the key settings using http it fails.
<add key="NuGet official package source" value="http://nuget.org/api/v2/" />

The source at nuget.org [https://www.nuget.org/api/v2/] is unreachable. Falling back to NuGet Local Cache at C:\Users\Terje\AppData\Local\NuGet\Cache

I also noted that it try to use the https even if I have specified http in the nuget.config, so that one seems to be ignored.

Using the Manage Packages for Solution it works with no hickups.

I have tried with elevated privileges for VS, still the same.

It doesn't happen with all packages though, just some. (NUnit works, NUnitTestAdapter doesn't)
Nov 14, 2014 at 6:03 PM
Looks like NuGet is down?
Feb 20, 2015 at 3:38 PM
All, I just change the link from https to http and it worked like a charm. Please try this.