NuGet Install-Package ignores nuget.config!

Topics: General
Apr 26, 2014 at 1:36 AM
Edited Apr 26, 2014 at 1:37 AM
This is driving me nuts.

As per I've created nuget.config file in the root of my solution:
PM> cat nuget.config
     <add key="repositoryPath" value=".\External\NuGetRepository" />
Removed any packages folder and restarted VS 2012:
PM> dir packages
dir : Cannot find path <mysolutionpath>\packages' because it does not exist.
But when I try to install a package it completely diregards the existence of the nuget.config:

PM> Install-Package Newtonsoft.Json 
Installing 'Newtonsoft.Json 6.0.2'.
Successfully installed 'Newtonsoft.Json 6.0.2'.
Adding 'Newtonsoft.Json 6.0.2' to UniversalProxyTrafficConverter.
Successfully added 'Newtonsoft.Json 6.0.2' to UniversalProxyTrafficConverter.

PM> dir packages
    Directory: <mySolutionPath>\packages
Mode                LastWriteTime     Length Name                                                                                                                                                 
----                -------------     ------ ----                                                                                
d----         4/25/2014   6:33 PM            Newtonsoft.Json.6.0.2                                                                                                                        
-a---         4/25/2014   6:33 PM        157 repositories.config                                                                                                                                  
There is no debug or verbose args I was able to find that would reveal the mistery.

PS I am MS FTE you can see my alias in profile so feel free to reach me in corpnet.
May 2, 2014 at 11:10 PM
Installing latest 2.8 NuGet version resolved the issue. (it was occurring with 2.6)
Marked as answer by Mikler on 5/2/2014 at 4:10 PM