Installation of Install-Package EnterpriseLibrary.Common

Topics: General
Mar 24, 2014 at 4:41 PM
Hi,
I have an MVC app which I've been working with for over two years. When the new code is brough down from svn I always have to add a few nu-get packages
Install-Package fasterflect
Install-Package EnterpriseLibrary.Common
Install-Package EnterpriseLibrary.Data
Installs enterprise data components

The first one works fine. Once I get to the second one I get an error. It rolls back and tells me that I'm targeting an app that is based on framework 4.0. I noticed as the installation went along that it looked like it was trying to bring down this package but at version 6.X.

I read an article that implies that using these enterprise packages in the current form the are on nu-get requires VS 2012 because they are using framework 4.5. I am using 2010.

Please let me know what the truth is.

Thanks,
Neil