VS2012 doing infinite requests to custom nuget server when trying to recover packages on build time

Topics: General
Aug 15, 2013 at 2:30 PM
Edited Aug 15, 2013 at 3:00 PM
We're using nuget with our own private nuget package source , which requires username and password. (we're using the official feed as well)

listing and adding packages works ok, (using the console or the ui)

but when VS tries to restore missing packages at build time, it fails to do that and it retries infinitely

I'm using charles proxy so I see the requests being done:

GET /nuget/ HTTP/1.0
User-Agent NuGet/2.1.31022.9038 (Microsoft Windows NT 6.1.7601 Service Pack 1)

and the result is the html of login page:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/> <title>401 - Unauthorized: Access is denied due to invalid credentials.</title> <style type="text/css"> <!-- body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;} fieldset{padding:0 15px 10px 15px;} h1{font-size:2.4em;margin:0;color:#FFF;} h2{font-size:1.7em;margin:0;color:#CC0000;} h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF; background-color:#555555;} #content{margin:0 0 0 2%;position:relative;} .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;} --> </style> </head> <body>
<div id="header"><h1>Server Error</h1></div> <div id="content"> <div class="content-container"><fieldset> <h2>401 - Unauthorized: Access is denied due to invalid credentials.</h2> <h3>You do not have permission to view this directory or page using the credentials that you supplied.</h3> </fieldset></div> </div> </body>

anybody has any idea what could be the problem ?
Thank You