Update of solution-level packages not possible

Topics: Ecosystem, General
Aug 9, 2013 at 8:10 AM
I have been using NuGet for a while now and do like it a lot. But imho ever since the use of solution-level packages has been a bit fuzzy. Now with the latest package manager version 2.6.40627.9000 it seems to be entirely broken - or maybe I just missed a breaking change?

We have a bunch of self created solution-level packages. They have nothing but a .target and some content files in them. I can install them by managing any project and also by managing the solution in which case I have to select at least one project. (To me this seems to be already a bug because in earlier versions the project checkboxes were greyed out for solution-level packages.) The Installation works fine and the files get copied but the manager is not showing any installed package neither on the project nor the solution level. To be more precise: In the Installed packages tab I do not get any entry - the same in the Updates tab. In the Online tab the installed packages get a green bullet on the right top corner instead of the install button. No package.config file gets created upon installation.

Has there been a change on how packages get interpreted as solution-level packages eg do I need to set a new flag or something like that? Is there a bug in the newest NuGet version? Or what else am I missing?

Please note that this is quite an issue for us because the whole NuGet infrastructure appears halfway broken and we are relying quite heavily on it.
Aug 19, 2013 at 7:43 AM
As nobody responded to the discussion and I believe it is a bug I created an issue for it: https://nuget.codeplex.com/workitem/3590