Error when uploading a package.

Topics: General
Jul 22, 2013 at 2:30 PM
Hi everyone,

When I attempt to upload a package to, I get an error, "Failed to read the package file". There is no description of what exactly is wrong with the package so I thought I'd share my nuspec file to see if there's anything wrong with it.
<?xml version="1.0"?>
    <authors>Vince Panuccio</authors>
    <owners>Vince Panuccio</owners>
    <summary>A LESS preprocessor.</summary>
    <copyright>Copyright 2013</copyright>
    <tags>aspnet bundle bundling less minification minify javascript css performance</tags>

        <dependency id="RxLoader" version="[0.9,1.0)" />
        <dependency id="DotlessClientOnly" version="[1.3,2.0)" />
    <file src="bin\$configuration$\$id$.dll" target="lib\net40"  />
    <file src="..\..\NuGet\content\" target="content" />
I have uploaded packages before without any problems so I'm baffled as to what this might be.

Any help would be appreciated.
Jul 22, 2013 at 2:35 PM
can you upload the .nupkg file too?
Jul 23, 2013 at 11:04 AM
There's no upload functionality but I've shared it on SkyDrive.

Thanks for your help.
Jul 25, 2013 at 12:51 PM
Can anyone help me with this issue please?
Jul 25, 2013 at 3:08 PM
There's nothing wrong with your package. We have identified it as a bug on our gallery. We're actively fixing it.

I'll let you know once we've deployed the fix to the server. Thanks for your patience.
Jul 26, 2013 at 3:48 AM
Thank you for the update.

Jul 26, 2013 at 11:50 PM
The problem is fixed now. You should be able to upload your package. Let us know if you still encounter the error.