404 when pushing to NuGet.Server installation

Topics: General
Apr 3, 2013 at 10:53 PM
Following the directions found here:

I am unable to push packages to my server, and receive a 404. My application is located under Default Web Site/NuGetGallery. I have tried posting to http://server/NuGetGallery, http://server/NuGetGallery/, http://server/NuGetGallery/api/v2/package and http://server/NuGetGallery/api/v2/package/ with the same result. I have also tried it with and without an api key.

I have tried it on an IIS 7.5 installation as well as local IIS 8 Express.

Any suggestions on why this is not working or what I can do to troubleshoot? Elmah.axd provides no exceptions.
Apr 9, 2013 at 7:09 AM
I'm not an IIS expert but seems like something is configured properly in the IIS.
When you have created the WEB project using the VS, have you tried to run it locally and check if it works?
If you did and it did work, this problem has nothing to do with NuGet.

Hope that directed you a little bit

Apr 9, 2013 at 2:18 PM
I was able to resolve my issue by increase the maximum allowed request size.