can't download Microsoft.Bcl.Async

Topics: General
Mar 15, 2013 at 5:17 PM
I'm following the instructions on, but NuGet gives me the following message:

PM> Install-Package Microsoft.Bcl.Async -Pre
Install-Package : Unable to find package 'Microsoft.Bcl.Async'.
At line:1 char:1
  • Install-Package Microsoft.Bcl.Async -Pre
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
The package doesn't show up at all if I search in the Package Manager.

I have 2.2.40116.9051 installed in visual studio 2012

My visual studio is version 11.0.51106.01 Update 1.

Is there any reason why I shouldn't be able to get that package?
Mar 15, 2013 at 9:51 PM
They seem to have unlisted the package. My guess is they want people to use
Mar 15, 2013 at 11:14 PM
Seems a little weird they would pull something that was last updated Jan 31, 2013 in favor of something that was last updated April 26, 2012
Mar 15, 2013 at 11:37 PM
Do you still have an error now? When had some outage yesterday. I wonder if you hit the server during that time.
Mar 15, 2013 at 11:49 PM
still the same error
Mar 15, 2013 at 11:50 PM
Can you open Fiddler and see what the request returns? Do you have the NuGet feed enabled?
Mar 16, 2013 at 12:06 AM
Ok. Thanks. That fixed it.

Not sure what caused it though.

There was an "Official NuGet Package Source" that was enabled, and a second " Official Nuget Package Source" that ends with 'v2' that was disabled.

I enabled the v2 one and restarted VS. now the first one is missing and the v2 is the only one there and is enabled.

I now see the Microsoft.Bcl.Async package.

Perhaps I never restarted VS after the last upgrade??? Not sure, but its fixed now.... Thanks.