404 File Not Found installing from local nuget server

Topics: General
Feb 4, 2013 at 7:57 PM
I apologize for sounding like a broken record, but I just cannot get this working.

I created a NuGet server:
  1. Using Visual Studio 2012, new project "ASP.NET Empty Web Application"
  2. Changed the project to be .NET 4.0 instead of 4.5 (our server does not have 4.5 and I cannot install it)
  3. Used NuGet to install Nuget.Server (2.2.2)
  4. Published the application via "File System".
On the server (Windows 2008 R2 with IIS 7.5):
  1. Created new root web site
  2. App pool is integrated mode running .NET v.4.0
  3. Copied 3 packages into ~/Packages (flat, no hierarchy)
  4. Verified that .nupkg is associated to application/zip
On my client (Windows 8):
  1. Navigate to http://nuget.mycompany.com/ and I see the basic nuget info
  2. Added http://nuget.mycompany.com/nuget to Visual Studio's NuGet source
  3. I can see my packages when browsing in NuGet, but when I install one, I get a 404.
I grabbed fiddler, it says 404 on "GET /api/v2/package/mypackage/1.0.2 HTTP/1.0"

I looked at the server logs and it says the same thing.

I can navigate to http://nuget.mycompany.com/packages/mypackage.1.0.2.nupkg and the file will download.

I have tried everything from the following other threads:
I even tried this:
Nothing helped.

Is there anything else I can do to diagnose the problem?
Feb 6, 2013 at 2:14 PM
hi,
  1. Open the site's properties in IIS6
  2. Navigate to the "Home Directory" tab
  3. Click the "Configuration" button:
This will then open the "Application Configuration" window:

Now you'll need to add the aspnet_isapi.dll mapping, the path of this will depend on the whether you're running Windox 64bit or not:
32bit Framework: c:\windows\microsoft.net\framework\v4.0.30319\aspnet_isapi.dll
64bit Framework: c:\windows\microsoft.net\framework64\v4.0.30319\aspnet_isapi.dll
Make sure you uncheck the "Verify that file exists" checkbox

i hope it is useful to you,find more details click here
Feb 6, 2013 at 2:29 PM
As previously mentioned, I am using IIS 7.5, not IIS 6.