NuGet Hangs Loading Manage Dialog

Topics: General
Dec 6, 2012 at 5:54 PM


When I open the Manage NuGet Packages dialog, I get a popup that reads "Loading the projects is required to complete the requested action.  If you click the Cancel button, project loading will continue in the background and you can try to perform the action again later  Loading project 1 of 6:"  It doesn't appear to every make any progress.  I've let it spin for a few hours.  If I cancel and try to close the Manage NuGet Packages dialog it crashes visual studio.

This only happens for one of my solutions, which happens to have 16 projects, not 6.  I've tried disabling addons, but none that can be disabled had an effect.

I'm using Visual Studio 2012 with NuGet Package Manager 2.1.31002.9028

Other extensions I have are HTML Spell Checker, JustCode, Kendo UI for ASP.NET MVC VSExtensions, Microsoft Visaul Studio PerfWatson, Microsfot Web Developer Tools, NCrunch for Visual Studio, Productivity Power Tools, Red Gate SQL Connect, Telerik WinForms VS Extensions, Visaul Studio Extensions for Windows Library for JavaScript

Any guidance on how to fix or debug this problem would be appreciated.

Dec 6, 2012 at 6:17 PM

this looks similar to, is it possible you could share your project in the bug (or a trimmed down project with the repro) and I can try it on my machine to find the cause?


Dec 6, 2012 at 9:23 PM

While trying to reproduce the issue in a solution I could share with you, the issue went away magically as it has done in the past.  Every time I think I find a work around it doesn't work the next time.  Sometimes it's rebooting, sometimes its working offline with my source control...

If it happens again, I'll try to get something that reproduces the issue.  This issue is unpredictably recurring for me, so if there's anything I can do to help figure this out please let me know.


Dec 10, 2012 at 1:47 PM

Had the same issue

  • Clearing the package Cache did not help.
  • Deleteing and restoring the packages in the package folder did not help.
  • The packages.config files seemed to be correct

Deleting the Solution.suo file solved the problem!

Has anyone any idea how the *.suo file settings influence the NuGet package manager behavior?



Dec 11, 2012 at 6:42 PM

It happened again and deleting the Solution.v11.suo worked for me as well.

Thanks for the work-around!

Dec 11, 2012 at 6:47 PM
Edited Dec 11, 2012 at 6:47 PM

@KrisHuggins can you please share your project with the bad suo file by opening an issue here (you might want to trim down the project with just the suo file for a repro)


Dec 12, 2012 at 12:23 AM

There is also this tool here which you would like to try to send the record and send the performance feedback of Visual studio.

More details can be found here

Feb 19, 2013 at 1:25 PM
Wow, it worked! I never thought deleting a .suo file would solve my problems! I was avoiding using NuGet because every time I used it my Visual Studio crashed. And now it's faster then ever. Thanks guys. What was NuGet doing with my user file anyway?
Feb 21, 2013 at 8:19 AM
I also have the same issue . The key step for me was/is deleting the whole ./package directory that's created in the solution by nuget.

This works, but I have to delete it every time I want to run "manage nuget packages for solution". This was especially frustrating as it took a few goes to successfully install my package across multiple projects as I'd forgotten to check out some files. Each attempt I had to delete the package dir, restart VS, attempt to install my package (EntityFramework), and if there were any issues, start the whole thing over again as loading packages for solution would crash and there is no option to re-install a package for a specific project.

amazon kindle
Apr 3, 2013 at 6:03 PM
I've been working on alot of new code with new packages, so I have had to delete my .suo file more than 50 times in march. This solution is very annoying. I'll delete the file in the morning, need to add another package in the afternoon and end up crashing again.
Apr 18, 2013 at 2:10 PM
I'm having the same problem. I have to delete the projects .suo file multiple times a day. The only problem with this is that Visual Studio needs to crash first before I know that it's time to delete the .suo file again. Is there a solution for this yet? It's hard to get rid of the bugs in my own software with a Visual Studio that keeps crashing.
Apr 18, 2013 at 4:47 PM
@Omegaspecter, @VinneTrousers: When you say VS crashes, when exactly does it happen? What did you do to make it crash? Does it just crash when you launch VS, or when you invoke NuGet or something else?
Apr 18, 2013 at 7:22 PM
Also, can you collect the crash dump and upload it somewhere for us to take a look?
Apr 18, 2013 at 8:13 PM
First loading of the projects hangs. This happens right after I click 'Manage NuGet packages for solution'. Then I click cancel after a long while because there isn't any progress. After clicking cancel twice it crashes my Visual Studio. I don't have any
other option.
Apr 19, 2013 at 1:39 AM
If you just right click on a project node, instead of the solution node, and select "Manage NuGet packagess...", does it crash?
Apr 19, 2013 at 7:29 AM
No, it doesn't crash if I only manage packages for one project at a time.
I will try to catch the crash dump for you. I'm sure it will happen again today.
Apr 19, 2013 at 8:54 AM
Here's the dump.
I will remove it within a few days.
Apr 19, 2013 at 10:18 AM
Thanks. What version of NuGet are you running? And what folders do you have under the SolutionRoot\packages folder?
Apr 19, 2013 at 10:38 AM
It's version 2.2.40116.9051 and the projects in the packages folder are:

Apr 19, 2013 at 3:56 PM
Thanks. What more information I need from you: How many projects do you have in your solution? What are the project types?

Also, would you mind installing the version 2.5 Release Candidate and giving it a try to see if it still crashes with 2.5? You can download it here
Apr 19, 2013 at 5:54 PM
Hmm, I'm not seeing any NuGet assemblies loaded in the dump file.
Apr 20, 2013 at 11:21 AM
Wrong dump?
I'm sure that the NuGet packages that I've mentioned before are all part of my solution.

Apr 20, 2013 at 1:10 PM
When I tried to load the dump, I didn't see any NuGet assemblies loaded.

Can you answer two questions I posted earlier?

Thanks. What more information I need from you: How many projects do you have in your solution? What are the project types?

Also, would you mind installing the version 2.5 Release Candidate and giving it a try to see if it still crashes with 2.5? You can download it here
Apr 23, 2013 at 10:03 AM
Edited Apr 23, 2013 at 12:13 PM
Hi, I've installed version 2.5. It still crashes. My solution is a normal C# Windows Forms Application and contains 15 projects. One executable and 14 class libraries using .NET Framework 4.5.
Apr 23, 2013 at 12:07 PM
Are all the packages installed into the Windows Forms application or distributed among the libraries?

Also, can you try this test for me:
  1. Delete the .suo file and start VS.
  2. Open the Manage NuGet Packages for Solution dialog
  3. Without doing anything else, close the dialog.
  4. Restart VS
  5. Now open the dialog again. Will it crash?
Apr 23, 2013 at 7:38 PM
It looks like the Leonardo.* packages are your private packages?
Apr 24, 2013 at 9:28 AM
Edited Apr 24, 2013 at 9:29 AM
Yes, the packages are distributed among the libraries. So it's not just the startup project that contains NuGet packages.
I've performed the test and VS indeed crashes at point 5 of the test.
And yes, the Leonardo.* packages are my private packages.
Apr 24, 2013 at 1:52 PM
OK, so I want to try my luck with a quick fix. I attached a VSIX to this page:

Here's the direct link to download:

Could you follow these steps to help me get to the root of the problem?
  1. Uninstall your current NuGet build.
  2. Install my VSIX.
  3. Run VS from the command line with the /log switch like this: devenv.exe /log c:\log.xml (replace the path with the folder that you have write permission to)
  4. Now try to follow the repro steps again.
  5. If you see an error dialog, great. Close VS and send me the log.xml file.
  6. If it still crashes, then I'll figure out the next step :)
Thanks for your patience
Apr 24, 2013 at 5:13 PM
It crashed again and I've created two logfiles for you. One without crash and one with crash.
Apr 24, 2013 at 5:59 PM
Hmm, thanks for sending the logs but they don't help in case of crash. At this time, I've run out of ideas. Are you willing to share your solution (privately) with me? If not, do you want to download NuGet source code and debug it on your machine?
Apr 25, 2013 at 11:35 AM
I've tried debugging it with the latest source code of NuGet (2.7?). Only it doesn't hang in debug mode. Is it sandboxing the debug session? Will it create a new .suo file for each debug session? In that case I cannot reproduce it. Any suggestions?
Apr 25, 2013 at 6:09 PM
I don't think it creates new .suo file. If you reuse your existing solution, VS won't touch it.

So this mysterious bug may not happen in debug mode.

Any chance you can create another crash dump with the official 2.5 build? The last crash dump you shared didn't show any NuGet assemblies loaded, so I suspect it may not be the correct dump.
May 1, 2013 at 1:34 PM
I've cleaned up my solution by removing some solutions folders and reorganized my projects (Tests in test folder and other projects directly attached under the solution). It hasn't crashed since then. Can it have something to do with the number of solutions folders?
May 8, 2013 at 3:14 PM
I've also removed the solution folders and first indications are promising. It did hang once, but since deleting the .suo file one last time it hasn't hung again. I had 8 folders with 2-6 projects in each folder.
May 9, 2013 at 5:13 PM
Yup, we have seen many reports of deleting the .suo file solves the hang problem. It's frustrating for me too because I can't repro this problem on my end, no matter how hard I tried. I hope some of you will be able to clone the nuget repository and help us debug the root cause.