Simple NuGet server requires username/password to publish?

Topics: General
Oct 24, 2012 at 2:25 PM

I'm setting up a simple NuGet server in my environment (while we wait for the TeamCity server to get reconfigured to host packages) and having problems publishing packages to it.

Followed the steps to setup a repository from here:

http://docs.nuget.org/docs/creating-packages/hosting-your-own-nuget-feeds

Everything works fine. If I manually copy a package into the packages folder it shows up in the feed.

However when I go to publish a package with the command line it asks me to provide credentials for the site.

C:\packages>nuget push MyPackage.1.0.0.nupkg -s http://myserver/nuget APIKEY
Pushing MyPackage 1.0.0 to 'http://myserver/nuget'...
Please provide credentials for: http://myserver/nuget/
UserName:
Password:

The website is an IIS 7.5 site running under the Default Web Site (as an IIS application). Server is 2008 R2. Application Pool is running under ApplicationPoolIdentity (the built-in account). I've set the DefaultAppPool account to have write access to the Packages folder (which is underneath the site under wwwroot).

I'm not familiar with ApplicationPoolIdentity (a dropdown value in the bindings for the site) vs. DefaultAppPool (a group or user that was already set in the security for the folder). Are they the same? There is no account named ApplicationPoolIdentity or DefaultAppPool on the server so short of changing it to run under a domain account I don't know.

Hoping someone has insight. I would like to have remote users push packages up but stalled on this so for now I have to copy them manually.

Thanks.

Oct 30, 2012 at 8:09 PM

Hello bsimser,

Did you disable Anonymous Authentication?  In IIS 7.5, you can check this by opening inetmgr, selecting your site in the Connections tree view, and opening the Authentication feature.

Thanks,
Clay

May 30, 2013 at 11:00 PM
Sounds similar to what we are experiencing.. when we disable Anonymous Authentication we can no longer see the website nor push packages to our repository location.
Jun 13, 2013 at 6:55 PM
It was happening to me.
I had a root website with no web.config running .net 2.0 and an application (nugetserver) running .net 4.0

I fixed it by creating a website for nugetserver running .net 4.0