Force targetFramework

Topics: General
Sep 30, 2012 at 5:15 AM

I am working on a project that uses .Net 4.0.  One of its dependencies is log4net. The log4net package has versions compiled for 2.0 and 4.0 (among others), but the 4.0 version broke some of the remoting functionality.  I set targetFramework="net20" in all of my packages.config, but the assembly reference path hints still point to net40.  I know I can manually update the refferences to point to net20, but that kindof defeats the point.  Is there a way to get Nuget to properly update the reference paths?

 

Casey