nuget WinFx compile error

Topics: General
Aug 21, 2012 at 8:24 PM



I'm trying to clone and compile latest code using VS2010 Ultimate SP1 + SDK SP1 but I'm getting this error:


  Code Analysis Complete -- 0 error(s), 0 warning(s)  CommandLine.Test -> D:\workspace\GIT\nuget\test\CommandLine.Test\bin\Debug\NuGet.Test.dllC:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.WinFX.targets(269,9): error MC1000: Unknown build error, 'Could not load type'System.Reflection.AssemblySignatureKeyAttribute' from assembly 'mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089'.'  [D:\workspace\GIT\nuget\src\VisualStudio\VisualStudio.csproj]


Has anyone found a solution for this kind of problem?  I've tried this on two seperate systems with the same result.  




Aug 21, 2012 at 10:42 PM

Yup, this is a known issue. Do you have VS2012 installed on the same machine?

Aug 21, 2012 at 10:50 PM

No, I actually installed a fresh system with VS2010 Ultimate + SP1 since i thought it might be my system.  Still got the same issue.  When i switch to the 2.00 branch, I have no issues.

Aug 22, 2012 at 9:33 PM

I've just checked in the fix. Can you pull and try it?

Aug 24, 2012 at 3:48 AM

Excellent, this one is solved.   Theres a new error, but I'm guessing this is work in progress... maybe??


C:\workspace\Git\nuget_2\Build\NuGet.Test.targets(7,5): error : NuGet.Test.Serv
erExtensions.MirrorCommandTest.MirrorCommandUsesMirrorOperation: System.IndexOu
tOfRangeException : Index was outside the bounds of the array. [C:\workspace\Gi


Thanks for fixing that first issue.

Aug 24, 2012 at 8:15 AM

This is an intermittent test error. If you build it the second time, it should disappear :D

Aug 24, 2012 at 2:37 PM

Excellent, this worked, now it compiles.

Only build release gives errors:


C:\workspace\Git\nuget_2\Build\NuGet.Test.targets(7,5): error : NuGet.Test.Inte
ementPackagesEmptyFrameworkFolderInContent: Assert.Equal() Failure [C:\workspac
C:\workspace\Git\nuget_2\Build\NuGet.Test.targets(7,5): error : Position: First
 difference is at position 3 [C:\workspace\Git\nuget_2\test\Test.Integration\Te
C:\workspace\Git\nuget_2\Build\NuGet.Test.targets(7,5): error : Expected: Strin
g[] { "content\file1.txt", "content\file2.txt", "content\net40\_._" } [C:\works
C:\workspace\Git\nuget_2\Build\NuGet.Test.targets(7,5): error : Actual:   Strin
g[] { "content\file1.txt", "content\file2.txt", "content\net40\_._", "obj\x86\R
elease\", "obj\x86\Release\GenerateResource-csc
.write.1.tlog", "obj\x86\Release\", "obj
\x86\Release\GenerateResource-csc-cvtres.write.1.tlog" } [C:\workspace\Git\nuge
C:\workspace\Git\nuget_2\Build\NuGet.Test.targets(7,5): error :    at NuGet.Tes
g packageFile, IEnumerable`1 expectedFiles) in c:\workspace\Git\nuget_2\test\Te
st.Integration\NuGetCommandLine\NuGetCommandLineTest.cs:line 1529 [C:\workspace
C:\workspace\Git\nuget_2\Build\NuGet.Test.targets(7,5): error :    at NuGet.Tes
ilesElementPackagesEmptyFrameworkFolderInContent() in c:\workspace\Git\nuget_2\
test\Test.Integration\NuGetCommandLine\NuGetCommandLineTest.cs:line 399 [C:\wor

Aug 24, 2012 at 5:11 PM

Thanks. I'll looking into it.