Apr 19, 2012 at 6:55 PM
Edited Apr 19, 2012 at 6:56 PM
I created my own package containing some utility functions, call it Foo.Common.Core. It has a packages.config file with one line
<package id="log4net" version="1.2.10" allowedVersions="[1.2,)" />
I want to be able to use this with log4net 1.2.10 (and beyond) because some sites I'm working on have other dependencies that lock log4net down to =1.2.10.
Now I open my project, BarSite where I want to install Foo.Common.Core.
I check its packages.config and find
<package id="log4net" version="1.2.10" />
so when I run install-package Foo.Common.Core, why does it fail with this:
PM> install-package Foo.Common.Core
Attempting to resolve dependency 'log4net (>= 1.2)'.
Successfully installed 'log4net 1.2.11'.
Successfully installed 'Foo.Common.Core 1.0.4492.23014'.
Install failed. Rolling back...
Install-Package : Updating 'log4net 1.2.10' to 'log4net 1.2.11' failed. Unable to find versions of 'N2CMS, N2CMS.Library that are compatible with 'log4net 1.2.11'.
So it's reading the dependency correctly -- 1.2 or above, but not accepting the 1.2.10 that's already installed-- why?