NuGet 1.7 in Visual Studio 11 beta

Apr 9, 2012 at 8:21 PM

I'm trying to use NuGet 1.7 in Visual Studio 11 beta with a project that uses Entity Framework migrations (Update-Database etc.). But I can' get it working, this is how it beahves:

  • When the Package Manager Console (PMC) is loaded on VS startup (no solution loaded yet) I can execute Install-Package etc. but not Update-Database. I guess that is fine as I am not in an EF project yet. The prompt looks like "PM>".
  • So I click on a solution on the start page. The solution is loaded but PMC is left intact - EF commands still not available, prompt still being "PM>".
  • If I try to open the solution from desktop so that Visual Studio goes straight into it, PMC is seemingly adjusted for that solution - the prompt shows "PS C:\path\to\solution>", EF commands are available but NuGet commands seem to be missing - e.g., I can't execute Install-Package ("the term 'install-package' is not recognized...")

Is that some kind of bug? It looks suspicious to me that in the last bullet, the prompt seems to indicate pure PowerShell, not PMC. I wanted to reinstall NuGet but don't know how (downloading and executing will only offer VS2010 installs).

Apr 10, 2012 at 9:42 AM
Edited Apr 10, 2012 at 9:42 AM

Are  you running this on Windows 8? If so, it is a known bug for the first two bullets.

The last bullet is indeed a bug and we have just fixed it recently. Would you mind installing the latest nightly build and verifying if it fixes the last bullet?

You can download the nightly build vsix at:

Apr 10, 2012 at 10:35 AM
Edited Apr 10, 2012 at 10:42 AM

The OS is Win7 x64. So are you saying that even in the clean Visual Studio right after startup (no solution loaded yet) I should be able to access EF commands like Update-Database? Or what should be the bug for the first two bullets that you mentioned?

As for the third bullet, tried the CI build, PMC now says "Package Manager Console Host Version 1.9.30406.247" but the prompt still shows "PS Path/To/Repo>" instead of "PM>".

The third bullet seems to be fixed using the CI build (console shows "Package Manager Console Host Version 1.9.30406.247").

Apr 10, 2012 at 3:31 PM

Thanks for verifying the fix for third bullet.

We have a bug in win8 express where we don't execute the init.ps1 script after opening the solution that has EF installed. As a result, the EF commands are not available.

If it happens to you in Win7, please file a bug and describe in details the steps to repro it. If you can share your solution, that would help a lot too. If not, that's fine.

Apr 11, 2012 at 10:28 AM
Edited Apr 11, 2012 at 10:29 AM

Created (can't provide a solution but tried to be as specific as possible).

May 3, 2012 at 9:54 AM

I had the problem in VS2010 (didn't check with VS11) on Windows 8 x64 and installed it from the first link. It indeed works with that latest version.

Thanks a bunch! :)