Nothing in Library Package Manager works

Mar 1, 2012 at 5:34 AM


I'm having big problems with NuGet. Yesterday I managed to remove and reinstall nuget (

Now if I in submenu "Library Package Manager", click either "Package Manager Console", "Manage NuGet Packages for Solution...", "Package Visualizer" or "Package Manager Settings" absolutely nothing happens. No matter what I click in this submenu, nothing happens.

Any idea?



Mar 1, 2012 at 6:32 PM

I think, while removing it there are things that has not been deleted and when you install it again there must be conflict or error in the system. I say this because i encounter same problem as your. Hope this will resolved.



Team INA Leadership

Team INA Smart Goals


Mar 3, 2012 at 2:20 AM

I haven't seen this error, but it sure seems like the installation is corrupted. I recommend trying the re-install again, but after uninstalling this time, delete the extension's folder complete before re-installing. If you still have trouble after that, please let us know.

Mar 5, 2012 at 9:39 AM


When I unistall it, the extention folder i automatically removed. So I try install it again and it is exact same problem. I can't click anything in the Library Package Manager folder. :(

Any idea?

Mar 5, 2012 at 9:41 AM

Can you tell me the path where the extension's folder was located? Can you tell me what files are there after re-installing?

Mar 5, 2012 at 10:15 AM

Folder is...

D:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft Corporation\NuGet Package Manager\1.6.21215.9133



108.218 Eula.rtf
  2.112 extension.vsixmanifest
 65.320 NuGet.Cmdlets.dll
 86.824 NuGet.Console.dll
 21.288 NuGet.Console.Types.dll
351.016 NuGet.Core.dll
 95.528 NuGet.Dialog.dll
 95.528 NuGet.Dialog10.dll
 93.992 NuGet.DialogServices.dll
 91.432 NuGet.Options.dll
 18.216 NuGet.TeamFoundationServer.dll
 41.256 NuGet.Tools.dll
  4.146 NuGet.Tools.pkgdef
188.712 NuGet.VisualStudio.dll
 14.632 NuGet.VisualStudio.Interop.dll
 62.760 NuGetConsole.Host.PowerShell.dll
 17.704 NuGetConsole.Host.PowerShellProvider.dll


 0 file(s)  0 byte


 48.780 NuGet.Cmdlets.dll-Help.xml
 21.583 NuGet.Format.ps1xml
 12.509 NuGet.psd1
 22.215 nuget.psm1
 13.725 NuGet.Types.ps1xml
 14.644 Profile.ps1


 0 file(s)  0 byte


 0 file(s)  0 byte


      0 origin.psdor

 1 file(s)  0 byte


 15.970 0n2_bwlxmo8ivn6ch2f5akclc.psdsxs
 1 file(s)    15.970 byte


    357 origin.psdor.rels
 1 file(s)357 byte


  4.286 Package.ico
 30.929 PreviewImage.png
 2 file(s)    35.215 byte


    320 .rels
 1 file(s)320 byte

Total file count:
31 fil(es) 1.546.012 byte
29 folder(s)  


Mar 5, 2012 at 2:37 PM

Will you please start Visual Studio with logging enabled, by executing `devenv.exe /log c:\log.txt` (changing the location of the log file to suit your needs) and email the log to me (

Mar 5, 2012 at 3:49 PM

Looking at your log, there seem to be two errors:


    2012/03/05 15:46:01.310
    The process cannot access the file 'C:\Users\mora.FPR\AppData\Local\Microsoft\VisualStudio\10.0\ComponentModelCache\Microsoft.VisualStudio.Default.cache' because it is being used by another process.

    2012/03/05 15:46:01.518
    Extension Manager
    Extension will not be loaded because an extension with the same ID 'd4f5086c-54b9-4b07-bd22-af72d5b9228f' is already loaded at D:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Telerik\Telerik.CommonPackage\\...
    D:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Telerik\Telerik.CommonPackage\\

It might be that one of them is affecting NuGet (which does seem to be loaded correctly). Could you try disabling the Telerik extensions and restarting VS?