Problems uptading my nuget packages

Jan 19, 2012 at 12:53 PM

Hi, i'm having difficulties uptading my nuget packages. Can someone help me?
I added some images here that i think will explain better my problems.

Jan 19, 2012 at 4:48 PM

I just tried installing the version into my project and I was able to see the in the Updates tab. 

What is your project type? What framework does it target, i.e. 4.0 full or 4.0 client? 

Also, if you create a new project, do see the problem? 

Jan 19, 2012 at 5:08 PM

I just created a WindowsForms project from scratch, with full .net 4.0 as target... installed version from powershell, and the new version still doesn't appear in the Updates tab =/

Jan 19, 2012 at 5:09 PM

I said powershell, but meaning Package Manager Console =)

Jan 19, 2012 at 5:13 PM

And again from Package Manager Console, i tried this...

PM> Get-Package -Updates
No package updates are available from the current package source.

as you see, something is wrong in my environment =/

Jan 19, 2012 at 5:17 PM

Let me guess, are you from Turkey?

Jan 19, 2012 at 5:21 PM

No, I'm from Brazil.

I remembered something now, maybe it could be interfering in the process. I was not able to connect with vsgallery extensions, and found a solution that worked here. So my devenv.exe.config is with something like this:

      <servicePointManager expect100Continue="false" />
      <ipv6 enabled="true" />

Do you think it could be the problem?

Jan 19, 2012 at 5:22 PM

Can you open Fiddler while checking the Updates and report the response from

Jan 19, 2012 at 5:29 PM

I never used this tool before, really cool this Fiddler =)

here it it:

#    Result    Protocol    Host    URL    Body    Caching    Content-Type    Process    Comments    Custom   
10    200    HTTP    Tunnel to    0            devenv:1784           

Jan 19, 2012 at 5:33 PM

No, that's not the response that I need :). Here's what you need to do:

  • Go to Tools - Fiddler Options - HTTPS tab and enable the "Decrypt HTTPS traffic" option
  • Then check the Updates in VS
  • Switch back to Fiddler, click on the request to on the left.
  • Now look at the right panel. The upper section is Request, the lower section is Response.
  • Click on the Raw tab of both Request and Response sections and copy both contents here.
Jan 19, 2012 at 5:43 PM

Tunnel to:

Connection: Keep-Alive

A SSLv3-compatible ClientHello handshake was found. Fiddler extracted the parameters below.

Major Version: 3
Minor Version: 1
Random: 4F 18 55 B4 F3 78 A9 77 E0 F6 C2 FD 7D A1 1F 9D 06 AE 1D 64 55 A3 EF A2 C7 C5 D2 89 D0 E1 31 A7
SessionID: 49 12 00 00 DE 11 8A 9E 9F 73 D9 F8 6E 98 31 12 92 38 D6 66 64 9D 37 BF 15 36 24 E8 F7 BB 1F AA
    [002F]    TLS_RSA_AES_128_SHA
    [0035]    TLS_RSA_AES_256_SHA
    [0005]    SSL_RSA_WITH_RC4_128_SHA
    [0032]    TLS_DHE_DSS_WITH_AES_128_SHA
    [0038]    TLS_DHE_DSS_WITH_AES_256_SHA
    [0004]    SSL_RSA_WITH_RC4_128_MD5

GET /api/v2/Packages()?$filter=((((((tolower(Id)%20eq%20'communityefproviderwrappers.efproviderwrappertoolkit')%20or%20(tolower(Id)%20eq%20'communityefproviderwrappers.eftracingprovider'))%20or%20(tolower(Id)%20eq%20'entityframework'))%20or%20(tolower(Id)%20eq%20'nlog'))%20or%20(tolower(Id)%20eq%20'utfprlibrary.core'))%20or%20(tolower(Id)%20eq%20'utfprlibrary.entityframework'))%20or%20(tolower(Id)%20eq%20'utfprlibrary.windowsforms')&$orderby=Id HTTP/1.1
DataServiceVersion: 1.0;NetFx
MaxDataServiceVersion: 2.0;NetFx
User-Agent: NuGet Package Manager Console/1.6.21215.9133 (Microsoft Windows NT 6.1.7600.0)
Accept: application/atom+xml,application/xml
Accept-Charset: UTF-8
Accept-Encoding: gzip, deflate
Connection: Keep-Alive

Jan 19, 2012 at 5:45 PM

I did it right? =)

Jan 19, 2012 at 5:55 PM

That's only the request. I will need the response too.

Jan 19, 2012 at 6:04 PM

I could not copy the response here, because of an error... so i blogged it here.

Jan 20, 2012 at 4:11 PM

That doesn't help much. I need the raw html response. Try this. After collecting the network requests, select File - Save - All Session. It will save all sessions as a .saz file. Please zip it and upload somewhere. Thanks

Jan 24, 2012 at 12:20 PM

Ok, sorry for my lack of experience =)

Try here.

Jan 25, 2012 at 6:47 PM

Hmm, I see the the two requests for packages updates return normally. Not sure why it doesn't show up in updates.

Can you try it on another machine and see if the problem still persist?

What is your OS? What are your OS and VS locales? What is the version of your VS?

Jan 26, 2012 at 11:54 AM

Windows 7 (pt-br) , VS 2010 Ultimate (en-us)

Feb 1, 2012 at 7:56 PM

I installed a VS 2010 PRO, and still can't update my packages... =/

Sep 6, 2012 at 3:36 PM


Did you get a resolution for this as I am having a similar problem and it appears to be network related. I have tried my PC on another LAN and it worked ok.

Here is what is happening;

Nuget requests a tunnel : CONNECT HTTP/1.1

and then once established send a request for a package: GET /packages/Newtonsoft.Json.4.5.8.nupkg HTTP/1.0

Then nothing happens until the connection times out.  

Here is the raw info from fiddler on the request:

GET HTTP/1.0NuGet-Operation: InstallUser-Agent: NuGet Add Package Dialog/2.0.30625.9003 (Microsoft Windows NT 6.2.9200.0)Host:


HTTP/1.0 200 OKContent-Length: 1208398Content-Type: application/zipETag: 0x8CF4002FF5FC65BServer: Windows-Azure-Blob/1.0 Microsoft-HTTPAPI/2.0x-ms-request-id: de51e253-d1e3-4e78-977f-7fbc3ce0e00cx-ms-version: 2009-09-19x-ms-lease-status: unlockedx-ms-blob-type: BlockBlobAge: 197089Date: Thu, 06 Sep 2012 14:33:00 GMTLast-Modified: Sat, 04 Aug 2012 02:50:10 GMTConnection: close


My gut feelin is the main company firewall (SonicWall Pro) is dropping some packets or data to prevent the download.

Any ideas or help appreciated!

Sep 6, 2012 at 4:00 PM

Ok my gut feeling was correct but i dont know exactly what is causing it.

I plugged my laptop straight into the router to get rid of the firewall and it worked fine so im pretty sure its the firewall causing the issue.

Its a Sonicwall Pro.  My next gut feeling is its a protocol thats getting lost/dropped - something along the lines of GRE... something to do with SSL and tunnels.

Not sure if this can be fixed as the router is set to allow ALL traffic outwards.

Is there anything else that Nuget is doing when initiating these connections? Any special ports or protocols i can test for?


Sep 6, 2012 at 5:20 PM

I am totally flummoxed with with thing!

I have narrowed it down to a http GET but still something weird.

If i enter this URL in a browser on my laptop: which is the package for nhibernate the url is unknown.  However if i try it from other machines on the same network (all with DHCP identical settings) then it works.  So it points to an issue with my machine. However if i put my laptop on another network it downloads fine!

Its got me completely confused as to what the issue could be.

Something else is that the link works on another PC (in a browser) but the package wont download via Nuget in VS2010.

Can anyone help or give me any pointers cos im pulling my hair out now.