NuGet won't install.

Dec 21, 2011 at 3:52 AM
Edited Dec 21, 2011 at 3:53 AM

Fresh install of VS2010, then immediately installed VS2010 SP1. I went to Extension Manager->Online->NuGet->Download, and it downloads then immediately crashes with "VSIXInstaller.exe has encountered a problem and needs to close."

I'm running as administrator, UAC is disabled. Win7 Pro, fresh install 30 minutes ago.

Dec 21, 2011 at 4:01 AM

Can you install any other extension from Visual Studio?

Dec 21, 2011 at 4:51 AM

Yes I can, I did quite a few others ones after that one failed (NuGet is the first one I always install). Need any log files or anything?

Dec 21, 2011 at 4:53 AM

Yeah, probably a good idea. But first, check out our known issues and make sure you're not running into any of these.

Dec 21, 2011 at 5:03 AM

I don't see any of those issues applying to me. What log files do I need to provide? I did a quick search to see if I could find out which ones I should look for and the only reference I could find quickly was saying to look in temp for anything with VSIXInstaller_*, but those were all blank.

Dec 21, 2011 at 7:29 AM

This is a known bug, you must uninstall NuGet 1.5 manually from VS2010 SP1, before you install NuGet 1.6.

1, close vs2010 SP1

2, ControllPanel uninstall NuGet 1.5

3, start VS2010 SP1

4, download and install NuGet 1.6


Dec 21, 2011 at 2:04 PM

How can I uninstall something I don't have? Like I said in the first post, this was a fresh install of Windows and VS2010 w/sp1.

Dec 21, 2011 at 2:25 PM

The problem appears to have fixed itself... The only differences between today and yesterday was:

1. I was no longer connected to the VPN into my work.

2. When I started the machine up, it said it needed to reboot to apply changes. Before I turned it off there were no new updates, so I have no idea what this was all about.

I did reboot a few times last night to see if that would fix it before I posted here, but each time I reconnected to my office VPN. Since I'm at the office connect to the machine at home, I didn't need to connect the VPN... Strange.

Mar 5, 2012 at 8:17 PM

I have the same problem. i have a fresh installation of windows 7 professional 64 bit and visual studio 2010 professional service pack 1.

any other extension installs without problem, nuget crashes always with

"VSIXInstaller.exe has encountered a problem and needs to close."

Mar 6, 2012 at 6:36 PM

@mrt181 Behind a proxy?

Mar 7, 2012 at 9:29 AM

no, i am at home. windows is running in a vm (virtualbox 4.1.8)

Mar 7, 2012 at 2:13 PM

If you download the VSIX directly ( and run it, do you see any errors?

Mar 7, 2012 at 2:35 PM

I already tried this. i get the same crash.

Mar 7, 2012 at 2:38 PM

Can you send the VSIX installer log to, please?