Has updating to NuGet 1.6 borked my Visual Studio install?

Dec 13, 2011 at 8:58 PM

Hi,

after brief chat with David Ebbo on twitter it looks like there is a may be a bug or confilict that has resulted in my VS install being unusable.

  1. Start VS, get prompted for NuGet extension update.
  2. Install update, get hit with known issue as per 1.6 release notes.
  3. Uninstall NuGet, restart VS.
  4. Re-install, get this error on restart: http://twitpic.com/7sw379
    Could not load file or assembly 'Microsoft.VisualStudio.Shell.Interop.10.0, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d60a3a' or one of its dependencies. The system cannot find the file specified.
  5. Uninstalled nuget (and all other extensions- PowerTools, VSCommands). Get this error on every restart and several times in a VS session: http://twitpic.com/7sw55x
    The 'Microsoft.VisualStudio.Editor.Implementation.EditorPackage, Microsoft.VisualStudio.Editor.Implementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d60a3a' package did not load correctly.
  6. Attempting to open a cs file results in this error without the file opening: http://twitpic.com/7sweuq
    No exports were found that match the constraint:
        ContractName    Microsoft.VisualStudio.Text.Operations.ITextUndoHistoryRegistry
        RequiredTypeIdentity    Microsoft.VisualStudio.Text.Operations.ITextUndoHistoryRegistry

Starting VS with logging shows these entries:

191 ERROR Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\CommonExtensions\Microsoft\Editor\Microsoft.VisualStudio.Editor.Implementation.dll


Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellComponentModelHost 2011/12/13 21:06:33.491
192 ERROR Could not load file or assembly 'Microsoft.VisualStudio.TextManager.Interop.10.0, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\CommonExtensions\Microsoft\Editor\Microsoft.VisualStudio.Editor.Implementation.dll


Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellComponentModelHost 2011/12/13 21:06:33.495

It appears my Visual Studio install is dead in the water :/

Going to try to recover with a re-install of SP1.

 

 

Dec 14, 2011 at 8:55 AM

Am back in working order:

  1. Uninstalled SP1
  2. Repaired VS install
  3. Re-installed SP1
  4. Installed NuGet 1.6 extension
  5. Happy times!

Hopefully this is just a 'my machine' thing.

Dec 14, 2011 at 6:01 PM

Glad you got it fixed up. Sorry that you ran into all these issues. Hopefully it won't be something widespread!