nuget.server 1.6 problem

Dec 13, 2011 at 6:53 AM

Tried to update our internal nuget server, but it returns an error, when I click on the link "Click here to view your packages."

The error is the following:

The server encountered an error processing the request. The exception message is 'Could not load file or assembly 'NuGet.Core, Version=1.6.21205.9031, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)'. See server logs for more details. The exception stack trace is:

at NuGet.Server.DataServices.Packages.CreateDataSource() at System.Data.Services.DataService`1.CreateDataSourceInstance() at System.Data.Services.DataService`1.CreateProvider() at System.Data.Services.DataService`1.HandleRequest() at System.Data.Services.DataService`1.ProcessRequestForMessage(Stream messageBody) at SyncInvokeProcessRequestForMessage(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

Dec 13, 2011 at 5:34 PM

How did you update your server? Did you update the NuGet.Server package?

Dec 13, 2011 at 7:41 PM

Yes, I opened the solution, opened managed nuget packages, selected the updates tab, and I choose to update the Nuget.Server package, built the solution, published to a release directory and I copied the files to the server. The website itself starts, but as soon as I go to the packages, I get the error.

Dec 13, 2011 at 8:38 PM

Could you try updating the NuGet.Core package? I ended up publishing a bad package last night and it looks likely that's the cause.

Dec 14, 2011 at 5:42 AM

I had to remove the Nuget.Core package, and reinstall it : now the view packages is ok.
But in VS2010, when I try to search I get : Bad request - Error in query syntax

Dec 14, 2011 at 5:48 AM

I solved it by uninstalling Nuget Package Manager in VS2010 and reinstall it (again...) It's a bit dangerous to upload a package again without incrementing its version info, even when previous version was bad.

Dec 14, 2011 at 6:30 AM

Still have problems with publishing from commandline ... suddenly, it asks for credentials ... site is anonymous.
 if I try to provide credentials, or provide none, I get an error, No access to a c;losed stream

Dec 14, 2011 at 6:30 AM
Edited Dec 14, 2011 at 6:34 AM

Still have problems with publishing from commandline ... suddenly, it asks for credentials ... site is anonymous.
 if I try to provide credentials, or provide none, I get an error, No access to a c;losed stream

!!! I urgently need a solution... even when I revert to the old site, nuget keeps asking me for credentials and whatever I provide , it fails.


Dec 21, 2011 at 1:00 PM

I'm seeing the same thing. I updated our nuget.server and nuget.exe to 1.6 and suddenly it's asking for credentials when publishing a package. I switched back to version 1.5 and the problem went away. I can see a 401 in fiddler. After entering credentials it doesn't seem to retry the request and just says "Cannot access a closed Stream."

Dec 21, 2011 at 6:17 PM

Look at solution for credentials problems  (thx to jpree)