Unable to use NuGet anymore: The remote server returned an error: (500)

Dec 13, 2011 at 2:20 AM

First NuGet wouldn't work but said there was an update. But the update failed until I uninstalled the old version. Now it won't get anything from the internet, giving me the 500 (server) error.

:(

What can I do?

Dec 13, 2011 at 2:30 AM
Can you open fiddler and see if there is error in the response?

Sent from my Super Windows Phone

From: Nivram509
Sent: 12/12/2011 6:20 PM
To: Luan Nguyen
Subject: Unable to use NuGet anymore: The remote server returned an error: (500) [nuget:282722]

From: Nivram509

First NuGet wouldn't work but said there was an update. But the update failed until I uninstalled the old version. Now it won't get anything from the internet, giving me the 500 (server) error.

:(

What can I do?

Dec 13, 2011 at 2:39 AM

Same issue for me,  in the browser I punched in https://go.microsoft.com/fwlink/?LinkID=230477 (address listed as offical package source)

it redirects to https://nuget.org/api/v2/

which then displays this error:

The server encountered an error processing the request. The exception message is 'Customizable feeds that have the KeepInContent attribute set to false cannot be used when the MaxProtocolVersion of the data service is set to DataServiceProtocolVersion.V1.'. See server logs for more details. The exception stack trace is:

at System.Data.Services.DataServiceConfiguration.ValidateServerOptions(Boolean friendlyFeedsV1Compatible) at System.Data.Services.DataService`1.HandleRequest() at System.Data.Services.DataService`1.ProcessRequestForMessage(Stream messageBody) at SyncInvokeProcessRequestForMessage(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

 

hope this is helpful

Dec 13, 2011 at 4:37 AM

Thanks for the repsonse. Now, it is working, so I suspect bad juju on the server or my internet connection.

How I 'fiixed it"

1. Read your question.

2. Had dinner.

3. Found and installed Fiddler (very nice tool, I'm glad I had the problem so I found out about Fiddler!)

4. Tried to duplicate w/ Fiddler running, but NuGet works now. :)

Request Count: 10

Bytes Sent: 8,615 (headers:1337; body:7278)

Bytes Received: 7,261 (headers:1394; body:5867)

ACTUAL PERFORMANCE

--------------

Requests started at: 20:31:39.724

Responses completed at: 20:35:15.542

Aggregate Session duration: 00:07:15.034

Sequence (clock) duration: 00:03:35.8173441

DNS Lookup time: 120ms

TCP/IP Connect duration: 642ms

RESPONSE CODES

--------------

HTTP/200: 10

RESPONSE BYTES (by Content-Type)

--------------

?: 5,355

~headers~: 1,394

image/png: 512

Developer
Dec 13, 2011 at 5:50 PM

We pushed a bad commit to the gallery which affected the feeds. We rolled it back as soon as we realized something was wrong.