The schema version of '{Id}' is incompatible with version 1.5

Sep 1, 2011 at 4:32 AM

I'm trying to create a new release of StatLight and during publish (through the Package Explorer) I get the following message.

"The Package could not be uploaded: The schema version of 'StatLight' is incompatable with version 1.5.0.0 of NuGet. Please upgrade NuGet to the latest version from (some long link that transfers to nuget.org)

I'm using the Package Explorer version 2.0.0.0 (compatable with NuGet 1.5 and below.)

I've tried this with two different methods.

1. I downloaded the latest StatLight 1.4 package, deleted the contents and added the new contents, updated the metadata to reflect the new version # and then tried to publish (receiving the error above)

2. I create a new package from scratch. Copy/pasted the metadata from one UI to the other UI, added the tools folder and the StatLight contents into this folder. tried to publish and still (receiving the error above)

Any thoughts?

Sep 1, 2011 at 5:11 AM

that's weird. can you share your package so that I can take a look?

Sep 1, 2011 at 5:28 AM

Never mind, I can repro this myself. Investigating right now...

Coordinator
Sep 1, 2011 at 6:31 AM

We're looking into it. 

Coordinator
Sep 1, 2011 at 6:42 AM

Ok, please try again.

Sep 1, 2011 at 3:11 PM

Strange I didn't get a notification that anyone responded... I'll try again this evening (when I get home).

Sep 1, 2011 at 3:11 PM

Phil,

Could you elaborate on "Ok, please try again."? :) I've just stood up a local gallery server following the docs and using rev. 51 of the source. I'm getting the same error against my local server. Will updating to rev. 58 fix this issue for me.

Thanks,

John

Sep 1, 2011 at 4:31 PM

Ok, I remoted into home and was able to publish my package.

When I used my work computer to try to install the package it told me I had to upgrade NuGet - which was a bit of a pain. After I upgraded it appeared to work (through visual studio). (still trying to figure out how to upgrade my Chocolatey version of nuget) 

Sep 1, 2011 at 4:54 PM

@jwatson: when you refer to your local gallery, are you using the full Orchard gallery, or the NuGet.Server package?

Sep 1, 2011 at 5:30 PM

@davidebbo: I'm trying the full Orchard gallery by following (http://docs.nuget.org/docs/contribute/setting-up-a-local-gallery). I tried updating from the latest hg revision, rebuilding and pushing updates over to the web server but it wasn't pretty. Getting NH/ADO errors on missing TaskLease stuff. Will try blowing everything away and starting fresh.

Note: We have about 5 engineering groups and 100+ engineers in a secure/controlled environment so while public NuGet is nice, we can't go there for internal builds...we have to vet/scan/approve anything before using. Local, in-house NuGet gallery is a must.

Sep 2, 2011 at 6:07 PM

@jwatson3d: we have a newer gallery in development, which is significantly easier to deploy than this one (you pretty much build and run!). You can get it from https://github.com/NuGet/NuGetGallery. It's not completely finished, but is getting close. It would be great if you could give it a try and give us feedback. Thanks!

Sep 15, 2011 at 8:56 PM

I was experiencing the same error when I installed the full Nuget with Orchard following this guide http://espenao.posterous.com/create-nuget-gallery-with-orchard-using-the-i (I had no joy following http://docs.nuget.org/docs/contribute/setting-up-a-local-gallery).

In our use case (CI/VS2010 Integration), the orchard website is not needed. Instead I pulled down the latest code from codeplex and built it using build.cmd located in the root.I had VS2010 installed on the machine, but I don't think it is needed.

I then expanded the archive bin\NuGet\Server\server.zip to a convenient directory (lets call it [serverDir]). I then setup a website in IIS pointing to the [serverDir] listening on port 80. I changed the app pool to .Net 4.0. Everything else is default. I am using Windows Server 2008 R2 x64 with all the latest patches.

I then went to http://localhost/ and it worked like a champ. The splash page told me to set an api key. In this implementation, I believe there is only one API key for the entire feed, which is perfect for our use case. I set the key in [serverDir]\web.config. I set it to "apikey" to be easy (note: this breaks the package explorer push but not the nuget command line push).

The splash page also tells you how to push packages and list packages in VS2010/Nuget command line.

Now to figure out a way to remove all previous versions of a package that isn't too hackish (we only care about the latest version in our CI environment).

 

Sep 16, 2011 at 9:25 PM

@davidebbo Finally had time to tackle this and...it works! The tricky issue w/r/t the schema version error is that the source code for both the light-weight github version as well as the heavy-weight Orchard version both reference the 1.4 version of NuGet.Core. Simply performing an 'Update-Package NuGet.Core' will bring the local source tree of the server up to 1.5 and resolve this error (assuming your NuGet client is at 1.5).

I tried running all the necessary package updates but got into trouble with mini-profiler as Sam Saffron has updated from 1.7 to 1.9.1 and reworked support for EF (see http://stackoverflow.com/questions/6550046/using-mvc-mini-profiler-database-profiling-with-entity-framework-code-first/6743941#6743941). After several tries, I simply reverted the source and stuck with updating just NuGet.Core.

Jan 14, 2013 at 7:43 PM

this was useful for me http://stackoverflow.com/questions/12035976/nuget-versioning-issue-with-package-restore