Issues connecting to feed

Jul 2, 2011 at 4:17 AM

I am trying to use NuGet for the first time and am having issues.  I have version 1.4 and VS 2010 SP1 on Windows 7.  I don't have a firewall or proxy in the way but whenever I run the following commands I get the following errors:

PM> Get-Package -remote
Get-Package : One or more errors occurred.
At line:1 char:12
+ Get-Package <<<<  -remote
    + CategoryInfo          : NotSpecified: (:) [Get-Package], AggregateException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.GetPackageCommand
 
PM> Get-Package -ListAvailable
Get-Package : One or more errors occurred.
At line:1 char:12
+ Get-Package <<<<  -ListAvailable
    + CategoryInfo          : NotSpecified: (:) [Get-Package], AggregateException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.GetPackageCommand

Also when I try to do it through the dialog off the Right Click menu of References and choose Online it just says "One or more errors occurred."
I am not sure what setting I am missing or what I am doing wrong that I can't get it to work on a clean install.
Jul 2, 2011 at 5:20 AM

Strange. Couple suggestions:

  • Check the list of Package Sources in the package manager settings
  • Run fiddler while running those commands to see if any requests are made
Jul 2, 2011 at 5:40 AM

The only source listed is the one that points at Microsoft.  When running fiddler I can see that it does access the feed and that the feed does return valid data.

Jul 2, 2011 at 7:57 AM

Can you run Visual Studio with the /log switch and attach the log file?

Jul 2, 2011 at 2:10 PM

How do I attach it?  It is 368KB and I don't see any tool to attach a file.

Jul 2, 2011 at 2:35 PM

You can create an 'Issue', which lets you attach files. Click 'Copy to work item' in one of the messages in this thread to easily create one.

Jul 2, 2011 at 5:10 PM

I created the following issue: http://nuget.codeplex.com/workitem/1252