Why is version="[1.0,2)" an invalid version string?

Jun 9, 2011 at 2:52 PM

Why is the nuspec configuration invalid?

  <dependencies>
      <dependency id="zzzz" version="[1.0,2)" />
    </dependencies>

And instead needs me to replace 2 with 2.0 to pack?

Coordinator
Jun 9, 2011 at 3:20 PM

That sounds like a bug to me. Could you open one?

From: dotnetchris [email removed]
Sent: Thursday, June 09, 2011 7:52 AM
To: Phil Haack
Subject: Why is version="[1.0,2)" an invalid version string? [nuget:260782]

From: dotnetchris

Why is the nuspec configuration invalid?

<dependencies>
<dependency id="zzzz" version="[1.0,2)" />
</dependencies>

And instead needs me to replace 2 with 2.0 to pack?

Jun 9, 2011 at 3:31 PM
Edited Jun 9, 2011 at 3:31 PM

Added http://nuget.codeplex.com/workitem/1179

Developer
Jun 9, 2011 at 3:36 PM

It's a System.Version restriction, that said, we can infer 2.0 from 2.