NuGet Package Explorer File Associations

May 26, 2011 at 8:21 PM

Is there a way to get the NuGet Package Explorer associated with .nupkg files so I can double-click on them from Windows Explorer?

May 26, 2011 at 8:33 PM

Doesn't it work for you already? The ClickOnce installer does register with Windows to associate .nupkg and .nuspec extensions with itself, unless you had already assigned those to some other programs prior to installing Package Explorer. In which case, I suggest you uninstall Package Explorer, disassociate the .nupkg extension with the current program, and then reinstall Package Explorer.

May 26, 2011 at 8:35 PM

On my various machines, I confirm that just installing it correctly associated the extension.

May 26, 2011 at 8:42 PM

.nuspec works. .nupkg doesn't. Not sure why. It seems highly unlikely that nupkg was associated with anything else beforehand. I'll try an uninstall and reinstall

May 26, 2011 at 8:45 PM

so when you double click on a .nupkg file, what happens?

May 26, 2011 at 9:01 PM

Just uninstalled and re-installed - same again.

Double-click .nupkg, get the standard don't know this extension dialog: "Windows can't open this file ... What do you want to do? Use the web ... Select a program"

Type column in explorer just shows "NUPKG File", but for .nuspec, Type column shows "NuGet spec file" and launches Package explorer fine.

May 26, 2011 at 9:18 PM

So I uninstalled it a second time, and then searched the registry for any reference to nuspec or nupkg. I deleted the following keys:


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.nupkg]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.nupkg\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.nuspec]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.nuspec\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.nuspec\OpenWithProgids]
"NuGet.Package"=hex(0):

Reinstalled, but exactly the same issue - nuspec extension is correctly registered, but nupkg not. The phrase nupkg is now nowhere to be found in my registry.

May 26, 2011 at 9:35 PM

interesting. what is your OS?

May 26, 2011 at 9:36 PM

Rebooted my PC, uninstalled & reinstalled. Still no file association. I give up.

Still it's a great little utility. I'll just have to drag my nupkg files in from explorer for now.

May 26, 2011 at 9:37 PM

@dotnetjunky Win 7 Home Premium, 32 bit

May 26, 2011 at 9:41 PM

Sorry to see it's not working for you. Don't give up yet :)

I'll investigate this and will reply to this thread once I've found the solution.

May 27, 2011 at 12:09 AM

Hi, there is one key under: HKEY_CURRENT_USER\Software\Classes\.nupkg

Can you check to see what's in there? If something is there, delete it and reinstall Package Explorer.

 

 

May 27, 2011 at 6:05 AM

no, I only have HKEY_CURRENT_USER\Software\Classes\.nuspec

Jun 12, 2011 at 3:35 PM

Hi, I'm finally able to repro this bug on a new machine. I've fixed it for the next release of Package Explorer, which is next week.

Jun 12, 2011 at 3:42 PM

Wow, impressive! What was the cause?

Jun 12, 2011 at 6:05 PM

It's my mistake. I set both file associations for .nuspec and .nupkg to the same progId, and that's why only the .nuspec file is associated. They should be set to different progIds.