Issue #405: -version flag should work as a min version and not an exact match

Apr 20, 2011 at 5:15 PM
Edited Apr 21, 2011 at 9:24 AM

http://nuget.codeplex.com/workitem/405

I this feature from the command line http://twitpic.com/4n944y which involved modifying NuGet.Commands.InstallCommand.ExcecuteCommand().

Am currently fleshing out an integration test.

Anything further I need to do before submitting it for review?

Apr 21, 2011 at 12:00 AM
Edited Apr 21, 2011 at 9:24 AM

My fork https://hg01.codeplex.com/forks/damianh/405commandlineversionrange has the changes to InstallCommand as well as unit tests.

May 27, 2011 at 4:20 AM

Shoot, I should've done some more research before diving into the code.

I coded up a similar fork, discussion is here: http://nuget.codeplex.com/discussions/259017

Developer
May 27, 2011 at 4:22 AM

Did you ever send a pull request?

May 27, 2011 at 3:48 PM
Edited May 27, 2011 at 3:48 PM

@dfowler not sure if you are addressing me or the_chrismo

I thought that I had to instigate a discussion first, make sure that people are cool with the fix etc before sumbitting a pull request. Hence this thread and my comment in the issue itself http://nuget.codeplex.com/workitem/405 . Didn't get any response so... left it.

Re-reading this thread, I guess I didn't put a good enough description as to what I did in this post. Perhaps I thought this single changeset https://hg01.codeplex.com/forks/damianh/405commandlineversionrange/rev/71d6e2d89c03 was enough.

If you think the change is acceptable, will send a pull request. (Am probably way out-of-date for a pull request at this point, but will update)

FWIW, have been using a build of nuget.exe with my changes (using IVersionSpec) for retrieving 'tools' for some time now.