Cannot install Silverlight 4 package

Mar 11, 2011 at 7:47 AM

I have created a test package (using nuget pack) that has a 'lib\Silverlight 4.0' folder in which are a couple of Silverlight 4 DLLs.

I am using a local source i.e. a folder into which I just copy myTest.1.0.nupkg - since nuget pack does not work for local sources.

In VS 2010 Premium I have created a SL 4 class library.

When I try to install the package using the Add Library Package Reference dialog I get this error:

'MyTest 1.0' already installed.

Unable to find assembly references that are compatible with the target framework 'Silverlight,Version=v4.0'.

MyTest is not already installed.

I've tried renaming the lib folder to lib\sl4 with the same result.

What am I doing wrong?



Mar 11, 2011 at 9:27 PM

can you share your .nupkg file for us to take a look?

Mar 12, 2011 at 8:24 AM

Can I upload the file here - or do you need a link?

Mar 12, 2011 at 9:02 AM

I'm afraid  you can't upload here. You can upload somewhere else and give me the link.