Package not working

Jan 26, 2011 at 8:43 AM

I've followed the conventions and have my project laid out like so:





When I inspect the package with 7zip, it has content in the content folder.

Upon clicking on the Install button in the Add Library Package Reference it does nothing.

Also typing install-package EF4Templates in the package console also does nothing, it says installed, but no files show up in my project.

I must have done something goofy with it. Does my package have to include a .exe or a .dll file or something?

I left the package in the gallery so we can test.


Rick Ratayczak

Jan 26, 2011 at 4:16 PM

I have two questions:

What version of NuGet are you running? (type $host.Version in the console)

What kind of project are you installing the package into? I tried it and it worked fine for me.

Jan 26, 2011 at 4:23 PM

It works now, but it's not the same that you had last night before we discussed it.  At the time you didn't have a Content folder, which is why it seemingly did nothing.  Try clearing your IE cache and installing again.

Jan 26, 2011 at 6:16 PM

@dfowler I am using the latest version, I downloaded it today.

Yup David, that was it. Thanks again for your help!