Could not load file or assembly 'TTVSAddinDotNet.resources.module'...

Jan 13, 2011 at 11:02 PM

When I attempt to use Library Package Manager to Add Library Package Reference and click on the Online->NuGet official package source I get the following error:

Could not load file or assembly 'TTVSAddinDotNet.resources.module' or one of its dependencies. The system cannot find the file specified.

Further, when I click on Online->All, I get this error message: One or more errors occured.

I'm using Windows 7 Professional and Visual Studio 2010 Professional.

The Package Manager has one Available package source entry: 1.  NuGet official package source (http://go.microsoft.com/fwlink/?LinkID=206669).

I have tried uninstalling and then installing using Extension Manager to no avail.

I have tried installing using the latest download from this site.

Any help would be appreciated.

 

Jan 14, 2011 at 6:12 PM

As far as I know, NuGet doesn't have any file or assembly called 'TTVSAddinDotNet.resources.module'. What are the add-ins and extensions that you currently have? Can you try disabling all of them and see if you can repro it?

Jan 14, 2011 at 6:57 PM

In fact, I can't find any reference to this anywhere on the web.  Could this be something created on your side?

Jan 14, 2011 at 7:00 PM

The only add-in is TestTrack. Tried disabling it and retried -- same result.

NuGet Package Manager is the only extension.

Jan 14, 2011 at 7:13 PM

davidebbo,

I could not find any reference to the aforementioned module on the web either. Or any part of it (i.e. 'TTVSAddinDotNet')

If this is something created on my side, I can not imagine what it would be. I've never used the Library Package Manager before.

I've never built a MVC site before and was trying to work through the tutorial found at: http://www.asp.net/mvc/tutorials/getting-started-with-mvc3-part1-cs to get an idea of how it works. This occured when I attempted to do what is described at http://www.asp.net/mvc/tutorials/getting-started-with-mvc3-part4-cs .

Jan 14, 2011 at 7:33 PM

Located a reference to the module in the registry [Seapine TestTrack]... forgot to restart VS after disabling. Is working now.

Thanks!

Jan 14, 2011 at 8:14 PM

Good to hear, thanks!

Jan 27, 2011 at 5:02 AM

Having the same issue. Tried to restart VS and restart my machine.

I do have Testtrack installed, however I'm not aware of any references to it in VS

Jan 27, 2011 at 5:05 AM

Actually, you were right! I found TestTrack reference in Add-in Manager. Disabled it and restarted VS. Now everything works great!

Jun 27, 2011 at 8:00 PM

Yep, same for me.  Thanks for that TestTrack tip.

Cheers.

Jul 29, 2014 at 11:58 PM
Same issue with TestTrack, thanks guys!