List-Package always displays "No packages installed."

Dec 26, 2010 at 1:15 PM

I updated my version of nuget today to 1.0.11217.102. When I 'list-package', I'd expect to list packages, but it always says "No installed packages". I've tried completely uninstalling and then re-installing and it didn't fix it. I made sure I'm pointing to the right feed http://go.microsoft.com/fwlink/?LinkId=204820 and that it's selected in the package manager console window.

Also when I try to use the "Add Library Package Reference" for "Online" it says "An error occurred while processing this request". I tried searching for logs, but couldn't find any. 

Any help would be appreciated.

Developer
Dec 26, 2010 at 2:53 PM
Edited Dec 26, 2010 at 3:01 PM

List-Package (AKA Get-Package) always lists installed packages. If you want to see packages from the feed then do Get-Package -Remote.

As for the Online tab reporting the error, does that always happen? If you reopen the dialog does it fix itself? Can you try restarting VS?

Dec 26, 2010 at 6:04 PM

@dfowler - Thanks for pointing out the -remote switch. The dialog still has the error after restarting.

Dec 26, 2010 at 6:29 PM

Can you run fiddler at the same time to see the HTTP requests that are happening?  Thanks.

Dec 26, 2010 at 7:40 PM

@davidebbo - Here's the headers:

Request:

GET http://feed.nuget.org/ctp2/odata/v1/Packages()?$orderby=Rating%20desc,Id&$skip=0&$top=30 HTTP/1.1
DataServiceVersion: 1.0;NetFx
MaxDataServiceVersion: 2.0;NetFx
Accept: application/atom+xml,application/xml
Accept-Charset: UTF-8
Host: feed.nuget.org
If-Modified-Since: Fri, 24 Dec 2010 06:28:18 GMT
Connection: Keep-Alive

Response:

HTTP/1.1 304 Not Modified
Cache-Control: private
Server: Microsoft-IIS/7.5
DataServiceVersion: 1.0;
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Sun, 26 Dec 2010 20:37:39 GMT


Dec 26, 2010 at 8:04 PM

I see, you're using an old feed.  Can you trying using http://go.microsoft.com/fwlink/?LinkID=206669 instead?

Dec 26, 2010 at 9:37 PM

@davidebbo - Yup, that did the trick. Not sure why it didn't update. Thanks for your help!