"No items found"in Add Library Package Reference dialog

Nov 18, 2010 at 9:27 AM
Edited Nov 18, 2010 at 9:43 AM

I have accidently posted this under "Issue tracker" as well...

Hi guys,
I don't see any items when I right click on my MVC 3 project in VS2010 and open the Add Library Package Reference dialog.  It displays "No items found".  I've the default package source of http://go.microsoft.com/fwlink/?LinkID=204820.
Any ideas?

 

Just to add some more information, when I try to open Package Manager Console, I get this error message:

System.Management.Automation.CmdletInvocationException: Windows PowerShell updated your execution policy successfully, but the setting is overridden by a policy defined at a more specific scope.  Due to the override, your shell will retain its current effective execution policy of "AllSigned". Type "Get-ExecutionPolicy -List" to view your execution policy settings. For more information, please see "Get-Help Set-ExecutionPolicy." ---> System.Security.SecurityException: Security error.   at System.Management.Automation.MshCommandRuntime.ThrowTerminatingError(ErrorRecord errorRecord)   --- End of inner exception stack trace ---   at System.Management.Automation.Runspaces.PipelineBase.Invoke(IEnumerable input)   at System.Management.Automation.Runspaces.Pipeline.Invoke()   at NuGetConsole.Host.PowerShell.Implementation.PowerShellHost.Invoke(String command, Object input, Boolean outputResults)   at NuGetConsole.Host.PowerShell.Implementation.PowerShellHost.LoadStartupScripts()   at NuGetConsole.Host.PowerShell.Implementation.PowerShellHost.Initialize()   at NuGetConsole.Host.PowerShellProvider.PowerShellHostProvider.<>c__DisplayClass1.<CreatePowerShellHost>b__0(Object sender, EventArgs e)   at NuGetConsole.CommonExtensionMethods.Raise(EventHandler ev, Object sender, EventArgs e)   at NuGetConsole.Implementation.Console.ConsoleDispatcher.Start()   at NuGetConsole.Implementation.PowerConsoleToolWindow.MoveFocus(FrameworkElement consolePane)

Coordinator
Nov 18, 2010 at 2:50 PM
Did you click the online tab in the left column? We default to displaying installed packages.
Nov 18, 2010 at 3:30 PM

Yes, I did but still doesn't display anything.  I've tried all the tabs - Online, Installed & Updates.

Just been doing a bit more research - and could it be anything to do with our work/office network not allowing unsigned packages as part of the group policies?

Nov 18, 2010 at 6:57 PM

As long as you're able to access http://feed.nuget.org/ctp2/odata/v1/Packages, it should normally work.

Nov 18, 2010 at 7:58 PM

The message in the console is a known issue, which has been fixed in the latest default branch. To work around this, you need to disable the execution policy flag in group policy, which you may or may not be able to.

Nov 18, 2010 at 8:04 PM

To clarify, this issue of the console should not affect the Add Package Reference dialog. You should still be able to install packages with the dialog normally. 

Nov 18, 2010 at 8:20 PM
Version is CTP2. I've got a feeling that it's definitely got something to do with our work network restrictions or group policies as I've just installed the same package on my home PC and everything worked perfectly.
Nov 18, 2010 at 9:13 PM

You can use Fiddler to check network activities.