NuGet is not working properly with me

Nov 4, 2010 at 5:09 PM

Hello, I've tried to install NuPack on two different machines and both are not working with the 1st version CTP1 and "NuPack 10-26-2010 build" here are the configuration about the machines

  1. My Work Machine
    • Windows Server 2008 R2 Standard 64-bit
    • Visual Studio 2010 + Visual Studio 2008
    • Power Shell 2 (Configured from the Server Manager Features)
  2. My Laptop
    • Windows 7 Professional 64-bit
    • Visual Studio 2010 + Visual Studio 2008
    • I can't confirm that power shell is there but I think it's installed by default with VS2010

1st I don't have IntelliSense

2nd I got this error when I run List-Package


Get-Package : <html>
        <title>Runtime Error</title>
         body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} 
         p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
         b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
         H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
         H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
         pre {font-family:"Lucida Console";font-size: .9em}
         .marker {font-weight: bold; color: black;text-decoration: none;}
         .version {color: gray;}
         .error {margin-bottom: 10px;}
         .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }

    <body bgcolor="white">

            <span><H1>Server Error in '/ctp1' Application.<hr width=100% size=1 color=silver></H1>

            <h2> <i>Runtime Error</i> </h2></span>

            <font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">

            <b> Description: </b>An application error occurred on the server. The current custom error settings for this application prevent the det
ails of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local serve
r machine.

            <b>Details:</b> To enable the details of this specific error message to be viewable on remote machines, please create a &lt;customErrors
&gt; tag within a &quot;web.config&quot; configuration file located in the root directory of the current web application. This &lt;customErrors&gt; 
tag should then have its &quot;mode&quot; attribute set to &quot;Off&quot;.<br><br>

            <table width=100% bgcolor="#ffffcc">

&lt;!-- Web.Config Configuration File --&gt;

        &lt;customErrors mode=&quot;Off&quot;/&gt;



            <b>Notes:</b> The current error page you are seeing can be replaced by a custom error page by modifying the &quot;defaultRedirect&quot; 
attribute of the application&#39;s &lt;customErrors&gt; configuration tag to point to a custom error page URL.<br><br>

            <table width=100% bgcolor="#ffffcc">

&lt;!-- Web.Config Configuration File --&gt;

        &lt;customErrors mode=&quot;RemoteOnly&quot; defaultRedirect=&quot;mycustompage.htm&quot;/&gt;




At line:1 char:13
+ List-Package <<<< 
    + CategoryInfo          : NotSpecified: (:) [Get-Package], DataServiceClientException
    + FullyQualifiedErrorId : NuPack.VisualStudio.Cmdlets.GetPackageCmdlet


What is my problem and how can I solve it?


Nov 4, 2010 at 5:16 PM

Read the instructions on the download page for the second release:

Important: To use this build, you need to:

  • remove all the existing feeds that you have
  • add a new feed pointing to

See for more info on the format changes.

This build will not work with old nupkg files. If you get null reference exceptions, you're using an old nupkg file and need to rebuild it with the ctp2 exe.

It looks like you are pointing to an old feed.

Nov 4, 2010 at 10:33 PM

Thanks dfowler for the answer, when I changed the link 'List-Package' works and get everything BUT still the IntelliSense is not working plus adding package is not working also. Check the error below:

The term 'Add-Package' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.At line:1 char:12+ Add-Package <<<<  log4net    + CategoryInfo          : ObjectNotFound: (Add-Package:String) [], CommandNotFoundException    + FullyQualifiedErrorId : CommandNotFoundException

Nov 4, 2010 at 10:36 PM


Nov 5, 2010 at 11:07 AM

I have no IntelliSense support, either, although I followed the given instructions to use the new feed instead of the old one.

For me, neither NuPack v1 CTP 1 nor NuPack 10-26-2010 build works correctly.

Nov 5, 2010 at 11:10 AM

Run VS as Admin, go to Tools | Extension Manager and uninstall the VSIX completely. Get the 10-26 build, install, make sure the feed is

Also, what other extensions do you have installed?


Nov 5, 2010 at 11:18 AM

Hey Scott,

I followed your instructions and now everything is perfectly fine and works as intented, even IntelliSense support.

Thanks for your help!


Nov 5, 2010 at 3:48 PM

I just added some more details to the Download Page.